blob: ac2376d59a93bc3a77342af4dba2239e9dba66d5 [file] [log] [blame]
Patrick Williams92b42cb2022-09-03 06:53:57 -05001#
2# Copyright OpenEmbedded Contributors
3#
4# SPDX-License-Identifier: MIT
5#
6
7##################################################################
8# Specific image creation and rootfs population info.
9##################################################################
10
11IMAGE_BASENAME ?= "${PN}"
12IMAGE_VERSION_SUFFIX ?= "-${DATETIME}"
13IMAGE_VERSION_SUFFIX[vardepsexclude] += "DATETIME SOURCE_DATE_EPOCH"
Andrew Geisslerfc113ea2023-03-31 09:59:46 -050014IMAGE_NAME ?= "${IMAGE_LINK_NAME}${IMAGE_VERSION_SUFFIX}"
15IMAGE_LINK_NAME ?= "${IMAGE_BASENAME}${IMAGE_MACHINE_SUFFIX}"
16
17# This needs to stay in sync with IMAGE_LINK_NAME, but with INITRAMFS_IMAGE instead of IMAGE_BASENAME
18INITRAMFS_IMAGE_NAME ?= "${@['${INITRAMFS_IMAGE}${IMAGE_MACHINE_SUFFIX}', ''][d.getVar('INITRAMFS_IMAGE') == '']}"
19
20# The default DEPLOY_DIR_IMAGE is ${MACHINE} directory:
21# meta/conf/bitbake.conf:DEPLOY_DIR_IMAGE ?= "${DEPLOY_DIR}/images/${MACHINE}"
22# so many people find it unnecessary to include this suffix to every image
23# stored there, but other people often fetch various images for different
24# MACHINEs to the same downloads directory and then the suffix is very helpful
25# add separate variable for projects to decide which scheme works best for them
26# without understanding the IMAGE_NAME/IMAGE_LINK_NAME structure.
27IMAGE_MACHINE_SUFFIX ??= "-${MACHINE}"
Patrick Williams92b42cb2022-09-03 06:53:57 -050028
29# IMAGE_NAME is the base name for everything produced when building images.
30# The actual image that contains the rootfs has an additional suffix (.rootfs
31# by default) followed by additional suffices which describe the format (.ext4,
32# .ext4.xz, etc.).
33IMAGE_NAME_SUFFIX ??= ".rootfs"
34
35python () {
36 if bb.data.inherits_class('deploy', d) and d.getVar("IMAGE_VERSION_SUFFIX") == "-${DATETIME}":
37 import datetime
38 d.setVar("IMAGE_VERSION_SUFFIX", "-" + datetime.datetime.fromtimestamp(int(d.getVar("SOURCE_DATE_EPOCH")), datetime.timezone.utc).strftime('%Y%m%d%H%M%S'))
39 d.setVarFlag("IMAGE_VERSION_SUFFIX", "vardepvalue", "")
40}