blob: 92733388ce032e0fb801cf095f73135b15b0d09e [file] [log] [blame]
Mohaimen Alsamaraif59d0172021-08-17 09:34:22 -05001FILESEXTRAPATHS:prepend:kudo := "${THISDIR}/${PN}:"
mustafa17bef002021-03-29 17:15:22 -05002
3inherit systemd
Mohaimen Alsamaraif59d0172021-08-17 09:34:22 -05004RDEPENDS:${PN} += "bash"
Avenash Asai Thambidbdb48a2022-03-24 09:29:46 -05005SYSTEMD_SERVICE:${PN}:append:kudo = " cpu_detect_virtual.service \
Mustafa Shehabi5c19b5b2021-09-15 16:41:44 -05006 "
mustafa17bef002021-03-29 17:15:22 -05007
Mohaimen Alsamaraif59d0172021-08-17 09:34:22 -05008SRC_URI:append:kudo = " \
Mustafa Shehabi5c19b5b2021-09-15 16:41:44 -05009 file://virtual_sensor_config1p2G.json \
10 file://virtual_sensor_config2p2G.json \
11 file://virtual_sensor_config1p4G.json \
Mustafa Shehabi5c19b5b2021-09-15 16:41:44 -050012 file://cpu_detect_virtual.sh \
13 file://cpu_detect_virtual.service \
mustafa17bef002021-03-29 17:15:22 -050014 "
Mohaimen Alsamaraif59d0172021-08-17 09:34:22 -050015do_install:append:kudo() {
Charles Boyer2adad362021-11-24 15:58:03 -060016 install -d ${D}${libexecdir}/${PN}
Avenash Asai Thambidbdb48a2022-03-24 09:29:46 -050017 install -m 0755 ${WORKDIR}/cpu_detect_virtual.sh ${D}${libexecdir}/${PN}/cpu_detect_virtual.sh
Mustafa Shehabi5c19b5b2021-09-15 16:41:44 -050018 install -d ${D}${sysconfdir}/virtual-sensor/configurations/
19 install -m 0644 ${WORKDIR}/virtual_sensor_config1p2G.json ${D}${sysconfdir}/virtual-sensor/configurations/virtual_sensor_config1p2G.json
20 install -m 0644 ${WORKDIR}/virtual_sensor_config2p2G.json ${D}${sysconfdir}/virtual-sensor/configurations/virtual_sensor_config2p2G.json
21 install -m 0644 ${WORKDIR}/virtual_sensor_config1p4G.json ${D}${sysconfdir}/virtual-sensor/configurations/virtual_sensor_config1p4G.json
mustafa17bef002021-03-29 17:15:22 -050022 install -d ${D}${systemd_system_unitdir}
Mustafa Shehabi5c19b5b2021-09-15 16:41:44 -050023 install -m 0644 ${WORKDIR}/cpu_detect_virtual.service ${D}${systemd_system_unitdir}/cpu_detect_virtual.service
mustafa17bef002021-03-29 17:15:22 -050024}
Mustafa Shehabi5c19b5b2021-09-15 16:41:44 -050025