blob: 329d3f8edb048b3f6e021404735aa497c41f9375 [file] [log] [blame]
Andrew Geissler7e0e3c02022-02-25 20:34:39 +00001#
2# This class is used by yocto-check-layer script for additional per-recipe tests
3# The first test ensures that the layer has no recipes skipping 'installed-vs-shipped' QA checks
4#
5
6WARN_QA:remove = "installed-vs-shipped"
7ERROR_QA:append = " installed-vs-shipped"
8
9python () {
10 packages = set((d.getVar('PACKAGES') or '').split())
11 for package in packages:
12 skip = set((d.getVar('INSANE_SKIP') or "").split() +
13 (d.getVar('INSANE_SKIP:' + package) or "").split())
14 if 'installed-vs-shipped' in skip:
15 oe.qa.handle_error("installed-vs-shipped", 'Package %s is skipping "installed-vs-shipped" QA test.' % package, d)
16}