blob: a4ec6cd1ef82e8821d393d082b3c34397e8a8844 [file] [log] [blame]
Andrew Geissler7e0e3c02022-02-25 20:34:39 +00001SUMMARY = "A simple wrapper around optparse for powerful command line utilities."
2DESCRIPTION = "\
3Click is a Python package for creating beautiful command line interfaces \
4in a composable way with as little code as necessary. It's the "Command \
5Line Interface Creation Kit". It's highly configurable but comes with \
6sensible defaults out of the box."
7HOMEPAGE = "http://click.pocoo.org/"
8LICENSE = "BSD-3-Clause"
9LIC_FILES_CHKSUM = "file://LICENSE.rst;md5=1fa98232fd645608937a0fdc82e999b8"
10
Andrew Geissler5082cc72023-09-11 08:41:39 -040011SRC_URI[sha256sum] = "ca9853ad459e787e2192211578cc907e7594e294c7ccc834310722b41b9ca6de"
Andrew Geissler7e0e3c02022-02-25 20:34:39 +000012
13inherit pypi setuptools3 ptest
14
Patrick Williams2a254922023-08-11 09:48:11 -050015SRC_URI += "file://run-ptest"
Andrew Geissler7e0e3c02022-02-25 20:34:39 +000016
17RDEPENDS:${PN}-ptest += " \
18 ${PYTHON_PN}-pytest \
19 ${PYTHON_PN}-terminal \
20 ${PYTHON_PN}-unixadmin \
21"
22
23do_install_ptest() {
24 install -d ${D}${PTEST_PATH}/tests
25 cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
26 cp -rf ${S}/setup.cfg ${D}${PTEST_PATH}/
27 cp -rf ${S}/docs ${D}${PTEST_PATH}/
28}
29
30UPSTREAM_CHECK_REGEX = "click/(?P<pver>\d+(\.\d+)+)/"
31
32CLEANBROKEN = "1"
33
34RDEPENDS:${PN} += "\
35 ${PYTHON_PN}-io \
36 ${PYTHON_PN}-threading \
37 "
38
39BBCLASSEXTEND = "native nativesdk"