blob: 8787ddc359cc0a4b9a11d1fca3b3ba3ecdecdbab [file] [log] [blame]
Patrick Williams92b42cb2022-09-03 06:53:57 -05001SUMMARY = "GLOME Login Client"
2HOME_PAGE = "https://github.com/google/glome"
3DESCRIPTION = "GLOME is used to authorize serial console access to Linux machines"
4PV = "0.1+git${SRCPV}"
5
6LICENSE = "Apache-2.0"
7LIC_FILES_CHKSUM = "file://LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57"
8
9inherit meson pkgconfig
10
11DEPENDS += "openssl"
12
13S = "${WORKDIR}/git"
14SRC_URI = "git://github.com/google/glome.git;branch=master;protocol=https"
Patrick Williams2a254922023-08-11 09:48:11 -050015SRCREV = "48d28f82bd51ae4bccc84fbbee93c375b026596b"
Patrick Williams92b42cb2022-09-03 06:53:57 -050016
17FILES:${PN} += "${libdir}/security"
18
19PACKAGECONFIG ??= ""
20PACKAGECONFIG[glome-cli] = "-Dglome-cli=true,-Dglome-cli=false"
21PACKAGECONFIG[pam-glome] = "-Dpam-glome=true,-Dpam-glome=false,libpam"
22
23EXTRA_OEMESON = "-Dtests=false"
24