blob: 84ca499debc8be6944b862fdeb3a81634883dba5 [file] [log] [blame]
Lei YU7307bed2020-02-06 15:43:35 +08001SUMMARY = "Phosphor Power Sequencer services installation"
2PR = "r1"
3
4LICENSE = "Apache-2.0"
5LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
6
7inherit allarch
8
Patrick Williams12fc9392021-08-06 09:16:53 -05009RDEPENDS:${PN} += "phosphor-power-sequencer"
Lei YU7307bed2020-02-06 15:43:35 +080010
Patrick Williams12fc9392021-08-06 09:16:53 -050011ALLOW_EMPTY:${PN} = "1"
Lei YU7307bed2020-02-06 15:43:35 +080012
Patrick Williams12fc9392021-08-06 09:16:53 -050013pkg_postinst:${PN}() {
Lei YU7307bed2020-02-06 15:43:35 +080014 mkdir -p $D$systemd_system_unitdir/obmc-chassis-poweron@0.target.wants
15 mkdir -p $D$systemd_system_unitdir/multi-user.target.requires
16
17 LINK="$D$systemd_system_unitdir/obmc-chassis-poweron@0.target.wants/pseq-monitor.service"
18 TARGET="../pseq-monitor.service"
19 ln -s $TARGET $LINK
20
21 LINK="$D$systemd_system_unitdir/obmc-chassis-poweron@0.target.wants/pseq-monitor-pgood.service"
22 TARGET="../pseq-monitor-pgood.service"
23 ln -s $TARGET $LINK
24}
25
Patrick Williams12fc9392021-08-06 09:16:53 -050026pkg_prerm:${PN}() {
Lei YU7307bed2020-02-06 15:43:35 +080027 LINK="$D$systemd_system_unitdir/obmc-chassis-poweron@0.target.wants/pseq-monitor.service"
28 rm $LINK
29 LINK="$D$systemd_system_unitdir/obmc-chassis-poweron@0.target.wants/pseq-monitor-pgood.service"
30 rm $LINK
31}