blob: 53cf1cf774f81a38c864bd9bb052967b139c873b [file] [log] [blame]
Patrick Williamsc124f4f2015-09-15 14:41:29 -05001SUMMARY = "Device formfactor information"
2SECTION = "base"
3LICENSE = "MIT"
Brad Bishop6e60e8b2018-02-01 10:27:11 -05004LIC_FILES_CHKSUM = "file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
Patrick Williamsc124f4f2015-09-15 14:41:29 -05005PR = "r45"
6
7SRC_URI = "file://config file://machconfig"
8S = "${WORKDIR}"
9
10PACKAGE_ARCH = "${MACHINE_ARCH}"
11INHIBIT_DEFAULT_DEPS = "1"
12
13do_install() {
14 # Install file only if it has contents
15 install -d ${D}${sysconfdir}/formfactor/
16 install -m 0644 ${S}/config ${D}${sysconfdir}/formfactor/
17 if [ -s "${S}/machconfig" ]; then
18 install -m 0644 ${S}/machconfig ${D}${sysconfdir}/formfactor/
19 fi
20}