blob: 750f8c808a8e420a9d88b33f6910fbe9e3335ff2 [file] [log] [blame]
Brad Bishop316dfdd2018-06-25 12:45:53 -04001LICENSE = "MIT"
2LIC_FILES_CHKSUM = "file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
3SUMMARY = "Basic grub.cfg for use in EFI systems"
4
5RPROVIDES_${PN} += "virtual/grub-bootconf"
6
7inherit grub-efi-cfg
8
9S = "${WORKDIR}"
10
11GRUB_CFG = "${S}/grub-bootconf"
12LABELS = "boot"
13
14ROOT ?= "root=/dev/sda2"
15
16python do_configure() {
17 bb.build.exec_func('build_efi_cfg', d)
18}
19
20do_configure[vardeps] += "APPEND ROOT"
21
22do_install() {
23 install -d ${D}/boot
24 install -d ${D}/boot/EFI
25 install -d ${D}/boot/EFI/BOOT
26 install grub-bootconf ${D}/boot/EFI/BOOT/grub.cfg
27}
28
29FILES_${PN} = "/boot/EFI/BOOT/grub.cfg"