blob: 7da7897cf5e2ac862a6ebc8390e060bd3bdad77f [file] [log] [blame]
Brad Bishopd7bf8c12018-02-25 22:55:05 -05001require go-${PV}.inc
2require go-target.inc
Brad Bishop316dfdd2018-06-25 12:45:53 -04003
4export GO_TARGET_INSTALL = "cmd"
5export GO_FLAGS = "-a"
6export CC_FOR_TARGET = "${CC}"
7export CXX_FOR_TARGET = "${CXX}"
8
9do_compile() {
10 export GOBIN="${B}/bin"
11 export TMPDIR="$GOTMPDIR"
12 export CC=$BUILD_CC
13
14 cd src
15 ./make.bash
16 cd ${B}
17}
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080018
19# for aarch64 ends with textrel in ${PN}
20# http://errors.yoctoproject.org/Errors/Details/185634/
21# ERROR: QA Issue: ELF binary '/work/aarch64-oe-linux/go/1.9.7-r0/packages-split/go/usr/lib/go/bin/go' has relocations in .text
22# ELF binary '/work/aarch64-oe-linux/go/1.9.7-r0/packages-split/go/usr/lib/go/pkg/tool/linux_arm64/trace' has relocations in .text
23# ELF binary '/work/aarch64-oe-linux/go/1.9.7-r0/packages-split/go/usr/lib/go/pkg/tool/linux_arm64/pprof' has relocations in .text [textrel]
24INSANE_SKIP_${PN} += "textrel"