blob: 3a1eb2c6ef2b9daeee70935b337c4c49110ae96c [file] [log] [blame]
Chanh Nguyen2fc68eb2022-04-28 09:11:28 +00001SUMMARY = "Phosphor OpenBMC Platform Init Service"
2DESCRIPTION = "Phosphor OpenBMC Platform Init Daemon"
3
4PR = "r1"
5LICENSE = "Apache-2.0"
6LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
7
8inherit systemd
9inherit obmc-phosphor-systemd
10
11DEPENDS += "systemd"
12RDEPENDS:${PN} += "libsystemd"
13RDEPENDS:${PN} += "bash"
14
15SRC_URI = " \
16 file://ampere-platform-init.service \
17 file://ampere-bmc-heartbeat.service \
18 file://ampere_platform_init.sh \
19 file://ampere_bmc_heartbeat.sh \
Hieu Huynhb953dc92022-09-12 18:35:36 +070020 file://mtmitchell_platform_gpios_init.sh \
Chanh Nguyen2fc68eb2022-04-28 09:11:28 +000021 file://gpio-lib.sh \
22 "
23SYSTEMD_PACKAGES = "${PN}"
24SYSTEMD_SERVICE:${PN} = "ampere-platform-init.service ampere-bmc-heartbeat.service"
25
26do_install () {
27 install -d ${D}${sbindir}
28 install -m 0755 ${WORKDIR}/gpio-lib.sh ${D}${sbindir}/
29 install -m 0755 ${WORKDIR}/ampere_platform_init.sh ${D}${sbindir}/
30 install -m 0755 ${WORKDIR}/ampere_bmc_heartbeat.sh ${D}${sbindir}/
Hieu Huynhb953dc92022-09-12 18:35:36 +070031 install -m 0755 ${WORKDIR}/mtmitchell_platform_gpios_init.sh ${D}${sbindir}/platform_gpios_init.sh
Chanh Nguyen2fc68eb2022-04-28 09:11:28 +000032 install -d ${D}${systemd_unitdir}/system/
33 install -m 0644 ${WORKDIR}/ampere-platform-init.service ${D}${systemd_unitdir}/system
34}
35