blob: 2c3f0b441ba725ed9f2d428d66c9f6c76e775b75 [file] [log] [blame]
Brad Bishop26bdd442019-08-16 17:08:17 -04001SUMMARY = "Xilinx Runtime(XRT) driver module"
2DESCRIPTION = "Xilinx Runtime driver module provides memory management and compute unit schedule"
3
Andrew Geissler84ad7c52020-06-27 00:00:16 -05004LICENSE = "GPLv2 & Apache-2.0"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=7d040f51aae6ac6208de74e88a3795f8"
Brad Bishop26bdd442019-08-16 17:08:17 -04006
Andrew Geissler84ad7c52020-06-27 00:00:16 -05007BRANCH ?= "2020.1"
8REPO ?= "git://github.com/Xilinx/XRT.git;protocol=https"
9BRANCHARG = "${@['nobranch=1', 'branch=${BRANCH}'][d.getVar('BRANCH', True) != '']}"
10SRC_URI = "${REPO};${BRANCHARG}"
Brad Bishop26bdd442019-08-16 17:08:17 -040011
Andrew Geissler84ad7c52020-06-27 00:00:16 -050012PV = "202010.2.6.0"
13SRCREV ?= "2d6bfe4ce91051d4e5b499d38fc493586dd4859a"
Brad Bishop26bdd442019-08-16 17:08:17 -040014
Andrew Geissler84ad7c52020-06-27 00:00:16 -050015S = "${WORKDIR}/git/src/runtime_src/core/edge/drm/zocl"
Brad Bishop26bdd442019-08-16 17:08:17 -040016
17inherit module
Andrew Geissler84ad7c52020-06-27 00:00:16 -050018
19pkg_postinst_ontarget_${PN}() {
20 #!/bin/sh
21 echo "Unloading old XRT Linux kernel modules"
22 ( rmmod zocl || true ) > /dev/null 2>&1
23 echo "Loading new XRT Linux kernel modules"
24 modprobe zocl
25}