blob: de9a02f2711d2baeba93fff17033b55fb10d6ab6 [file] [log] [blame]
Brad Bishopba470942017-07-21 22:05:22 -04001# WARNING!
2#
3# These modifications to os-release disable the bitbake parse
4# cache (for the os-release recipe only). Before copying
5# and pasting into another recipe ensure it is understood
6# what that means!
7
Brad Bishop05ce9c52015-11-19 22:06:41 -06008def run_git(d, cmd):
Brad Bishop7019fbe2017-07-21 21:47:44 -04009 try:
10 oeroot = d.getVar('COREBASE', True)
Patrick Williamsbc442de2020-11-18 12:29:25 -060011 return bb.process.run(("export PSEUDO_DISABLED=1; " +
12 "git --work-tree %s --git-dir %s/.git %s")
Brad Bishop7019fbe2017-07-21 21:47:44 -040013 % (oeroot, oeroot, cmd))[0].strip('\n')
Patrick Williamsbc442de2020-11-18 12:29:25 -060014 except Exception as e:
15 bb.warn("Unexpected exception from 'git' call: %s" % e)
Brad Bishop7019fbe2017-07-21 21:47:44 -040016 pass
Brad Bishopbe861802015-11-11 13:56:17 -050017
Patrick Williams24d05d02021-06-30 16:15:45 -050018# DISTRO_VERSION can be overridden by a bbappend or config, so it must be a
19# weak override. But, when a variable is weakly overridden the definition
20# and not the contents are used in the task-hash (for sstate reuse). We need
21# a strong variable in the vardeps chain for do_compile so that we get the
22# contents of the 'git describe --dirty' call. Create a strong/immediate
23# indirection via PHOSPHOR_OS_RELEASE_DISTRO_VERSION.
24PHOSPHOR_OS_RELEASE_DISTRO_VERSION := "${@run_git(d, 'describe --dirty')}"
25DISTRO_VERSION ??= "${PHOSPHOR_OS_RELEASE_DISTRO_VERSION}"
26
Patrick Williams46d9de32020-11-17 15:42:09 -060027VERSION = "${@'-'.join(d.getVar('VERSION_ID').split('-')[0:2])}"
Brad Bishop05ce9c52015-11-19 22:06:41 -060028
Patrick Williams46d9de32020-11-17 15:42:09 -060029BUILD_ID := "${@run_git(d, 'describe --abbrev=0')}"
30OPENBMC_TARGET_MACHINE = "${MACHINE}"
Brad Bishop05ce9c52015-11-19 22:06:41 -060031
Patrick Williams12fc9392021-08-06 09:16:53 -050032OS_RELEASE_FIELDS:append = " BUILD_ID OPENBMC_TARGET_MACHINE EXTENDED_VERSION"
Brad Bishopba470942017-07-21 22:05:22 -040033
34# Ensure the git commands run every time bitbake is invoked.
35BB_DONT_CACHE = "1"
Brad Bishope384d0c2017-07-24 20:24:28 -040036
37# Make os-release available to other recipes.
Patrick Williams12fc9392021-08-06 09:16:53 -050038SYSROOT_DIRS:append = " ${sysconfdir}"