blob: be10800389cf9f6c8b00ae86b7368a62301b6d57 [file] [log] [blame]
Andrew Geissler82c905d2020-04-13 13:39:40 -05001require gstreamer1.0-plugins-common.inc
2
3LIC_FILES_CHKSUM = "file://COPYING;md5=a6f89e2100d9b6cdffcea4f398e37343 \
4 file://tests/check/elements/xingmux.c;beginline=1;endline=21;md5=4c771b8af188724855cb99cadd390068"
5
6LICENSE = "GPLv2+ & LGPLv2.1+ & LGPLv2+"
7LICENSE_FLAGS = "commercial"
8
9SRC_URI = " \
10 https://gstreamer.freedesktop.org/src/gst-plugins-ugly/gst-plugins-ugly-${PV}.tar.xz \
11 "
12SRC_URI[md5sum] = "10283ff5ef1e34d462dde77042e329bd"
13SRC_URI[sha256sum] = "5500415b865e8b62775d4742cbb9f37146a50caecfc0e7a6fc0160d3c560fbca"
14
15S = "${WORKDIR}/gst-plugins-ugly-${PV}"
16
17DEPENDS += "gstreamer1.0-plugins-base"
18
19GST_PLUGIN_SET_HAS_EXAMPLES = "0"
20
21PACKAGECONFIG ??= " \
22 ${GSTREAMER_ORC} \
23 a52dec mpeg2dec \
24"
25
26PACKAGECONFIG[a52dec] = "-Da52dec=enabled,-Da52dec=disabled,liba52"
27PACKAGECONFIG[amrnb] = "-Damrnb=enabled,-Damrnb=disabled,opencore-amr"
28PACKAGECONFIG[amrwb] = "-Damrwbdec=enabled,-Damrwbdec=disabled,opencore-amr"
29PACKAGECONFIG[cdio] = "-Dcdio=enabled,-Dcdio=disabled,libcdio"
30PACKAGECONFIG[dvdread] = "-Ddvdread=enabled,-Ddvdread=disabled,libdvdread"
31PACKAGECONFIG[mpeg2dec] = "-Dmpeg2dec=enabled,-Dmpeg2dec=disabled,mpeg2dec"
32PACKAGECONFIG[x264] = "-Dx264=enabled,-Dx264=disabled,x264"
33
34EXTRA_OEMESON += " \
35 -Dsidplay=disabled \
36"
37
38FILES_${PN}-amrnb += "${datadir}/gstreamer-1.0/presets/GstAmrnbEnc.prs"
39FILES_${PN}-x264 += "${datadir}/gstreamer-1.0/presets/GstX264Enc.prs"