blob: 79fe68ab4ab0e097cc400e81c5ae79a67bac3649 [file] [log] [blame]
Deepak Kodihallifeb88672017-05-17 06:42:51 -05001SUMMARY = "Default settings"
2PR = "r1"
Brad Bishop75f03872018-11-03 09:41:57 -07003LICENSE = "Apache-2.0"
Brad Bishop6f3f0aa2019-09-13 12:14:05 -04004LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
Deepak Kodihallifeb88672017-05-17 06:42:51 -05005
Deepak Kodihallifeb88672017-05-17 06:42:51 -05006inherit phosphor-settings-manager
Joseph Reynolds79809ea2021-02-26 15:37:31 -06007inherit native
Deepak Kodihallifeb88672017-05-17 06:42:51 -05008
9SRC_URI += "file://defaults.yaml"
Allen.Wang7298b242022-03-09 14:44:27 +080010SRC_URI += "file://host-template.yaml"
Deepak Kodihallifeb88672017-05-17 06:42:51 -050011
12PROVIDES += "virtual/phosphor-settings-defaults"
13
14S = "${WORKDIR}"
15
16do_install() {
17 DEST=${D}${settings_datadir}
18 install -d ${DEST}
19 install defaults.yaml ${DEST}
Allen.Wang7298b242022-03-09 14:44:27 +080020
21 for i in ${OBMC_HOST_INSTANCES};
22 do
23 cat host-template.yaml | sed "s/{}/${i}/g" >> ${DEST}/defaults.yaml
24
25 done
Deepak Kodihallifeb88672017-05-17 06:42:51 -050026}