blob: c81eae6b91011530d661a29fdc6c26954f21dac6 [file] [log] [blame]
Brad Bishopba470942017-07-21 22:05:22 -04001# WARNING!
2#
3# These modifications to os-release disable the bitbake parse
4# cache (for the os-release recipe only). Before copying
5# and pasting into another recipe ensure it is understood
6# what that means!
7
Brad Bishop05ce9c52015-11-19 22:06:41 -06008def run_git(d, cmd):
Brad Bishop7019fbe2017-07-21 21:47:44 -04009 try:
10 oeroot = d.getVar('COREBASE', True)
11 return bb.process.run("git --work-tree %s --git-dir %s/.git %s"
12 % (oeroot, oeroot, cmd))[0].strip('\n')
13 except:
14 pass
Brad Bishopbe861802015-11-11 13:56:17 -050015
Brad Bishop05ce9c52015-11-19 22:06:41 -060016python() {
Brad Bishop7019fbe2017-07-21 21:47:44 -040017 version_id = run_git(d, 'describe --dirty --long')
18 if version_id:
19 d.setVar('VERSION_ID', version_id)
20 versionList = version_id.split('-')
21 version = versionList[0] + "-" + versionList[1]
22 d.setVar('VERSION', version)
Brad Bishop05ce9c52015-11-19 22:06:41 -060023
Brad Bishop7019fbe2017-07-21 21:47:44 -040024 build_id = run_git(d, 'describe --abbrev=0')
25 if build_id:
26 d.setVar('BUILD_ID', build_id)
Brad Bishop05ce9c52015-11-19 22:06:41 -060027}
28
Brad Bishopbe861802015-11-11 13:56:17 -050029OS_RELEASE_FIELDS_append = " BUILD_ID"
Brad Bishopba470942017-07-21 22:05:22 -040030
31# Ensure the git commands run every time bitbake is invoked.
32BB_DONT_CACHE = "1"