blob: 3fd0ff6cf4f77f4c9d50b9679db57f484e5cf9a4 [file] [log] [blame]
Andrew Geissler82c905d2020-04-13 13:39:40 -05001SUMMARY = "Sensors plugin for the Xfce Panel"
2HOMEPAGE = "http://goodies.xfce.org/projects/panel-plugins/xfce4-sensors-plugin"
3LICENSE = "GPLv2"
4LIC_FILES_CHKSUM = "file://COPYING;md5=b94789bed9aec03b9656a9cc5398c706"
5
6inherit xfce-panel-plugin
7
8SRC_URI[md5sum] = "7327c4c316ebd5d93665e77b432b8d89"
9SRC_URI[sha256sum] = "3dc6643d2c064b7718badff44b948f8d410f00f13db197820b26ae38045f5112"
10SRC_URI += "file://0001-Do-not-check-for-sys-class-power_supply-we-are-cross.patch"
11
12EXTRA_OECONF = " \
13 --disable-procacpi \
14 --disable-xnvctrl \
15"
16
17do_configure_prepend() {
18 sed -i 's:LIBSENSORS_CFLAGS=.*:LIBSENSORS_CFLAGS=-I${STAGING_INCDIR}:g' ${S}/configure.ac
19}
20
21PACKAGECONFIG[libsensors] = "--enable-libsensors,--disable-libsensors, lmsensors"
22PACKAGECONFIG[hddtemp] = "--enable-hddtemp,--disable-hddtemp, hddtemp"
23PACKAGECONFIG[netcat] = "--enable-netcat,--disable-netcat, netcat"
24PACKAGECONFIG[libnotify] = "--enable-notification,--disable-notification, libnotify"
25
26FILES_SOLIBSDEV = "${libdir}/xfce4/modules/lib*${SOLIBSDEV}"