blob: ec831eb5f15be9409e62e07592fcf7eae8ad8789 [file] [log] [blame]
Adriana Kobylakb96c7502021-08-06 16:25:30 +00001FILESEXTRAPATHS:prepend := "${THISDIR}/${BPN}:"
Brad Bishope1615142020-04-22 14:06:02 -04002
Adriana Kobylakb96c7502021-08-06 16:25:30 +00003PACKAGECONFIG:append:p10bmc = " host-dump-transport-pldm"
4PACKAGECONFIG:append:witherspoon-tacoma = " host-dump-transport-pldm"
Matt Spinlerb9e821a2018-03-29 16:34:38 -05005
Adriana Kobylakb96c7502021-08-06 16:25:30 +00006PACKAGECONFIG:append:p10bmc = " openpower-dumps-extension"
7PACKAGECONFIG:append:witherspoon-tacoma = " openpower-dumps-extension"
Dhruvaraj Subhashchandran21ebf782020-09-24 01:33:00 -05008
Matt Spinlerb9e821a2018-03-29 16:34:38 -05009SRC_URI += "file://plugins.d/ibm_elogall"
Matt Spinler06f97e42020-07-27 16:30:21 -050010SRC_URI += "file://plugins.d/pels"
Matt Spinlerb9e821a2018-03-29 16:34:38 -050011
12install_ibm_plugins() {
13
14 install -m 0755 ${WORKDIR}/plugins.d/ibm_elogall ${D}${dreport_plugin_dir}
Matt Spinler06f97e42020-07-27 16:30:21 -050015 install -m 0755 ${WORKDIR}/plugins.d/pels ${D}${dreport_plugin_dir}
Matt Spinlerb9e821a2018-03-29 16:34:38 -050016
17}
18
19#Link in the plugins so dreport run them at the appropriate time
20python link_ibm_plugins() {
21
22 workdir = d.getVar('WORKDIR', True)
23 script = os.path.join(workdir, 'plugins.d', 'ibm_elogall')
24 install_dreport_user_script(script, d)
Matt Spinler06f97e42020-07-27 16:30:21 -050025
26 script = os.path.join(workdir, 'plugins.d', 'pels')
27 install_dreport_user_script(script, d)
Matt Spinlerb9e821a2018-03-29 16:34:38 -050028}
29
Chirag Sharma4b5211d2020-09-29 08:18:17 -050030#Install dump header script from dreport/ibm.d to dreport/include.d
31install_dreport_header() {
32 install -d ${D}${dreport_include_dir}
PriyangaRamasamybcbcea82021-03-02 22:49:05 -060033 install -m 0755 ${S}/tools/dreport.d/ibm.d/gendumpheader ${D}${dreport_include_dir}/
Chirag Sharma4b5211d2020-09-29 08:18:17 -050034}
35
PriyangaRamasamy2e8e0142021-03-02 23:01:04 -060036#Install ibm bad vpd script from dreport/ibm.d to dreport/plugins.d
37install_ibm_bad_vpd() {
38 install -d ${D}${dreport_plugin_dir}
39 install -m 0755 ${S}/tools/dreport.d/ibm.d/badvpd ${D}${dreport_plugin_dir}
40}
41
42#Link in the plugins so dreport run them at the appropriate time based on the plugin type
43python link_ibm_bad_vpd() {
44 sourcedir = d.getVar('S', True)
45 script = os.path.join(sourcedir, "tools", "dreport.d", "ibm.d", "badvpd")
46 install_dreport_user_script(script, d)
47}
48
Chirag Sharma4b5211d2020-09-29 08:18:17 -050049IBM_INSTALL_POSTFUNCS = "install_ibm_plugins link_ibm_plugins"
Adriana Kobylakb96c7502021-08-06 16:25:30 +000050IBM_INSTALL_POSTFUNCS:p10bmc += "install_dreport_header install_ibm_bad_vpd link_ibm_bad_vpd"
Chirag Sharma4b5211d2020-09-29 08:18:17 -050051
52do_install[postfuncs] += "${IBM_INSTALL_POSTFUNCS}"