blob: 3641217306abebd098f819dfa47ebf2be3e6aa0f [file] [log] [blame]
Brad Bishopc342db32019-05-15 21:57:59 -04001require core-image-sato-sdk.bb
2require conf/distro/include/ptest-packagelists.inc
3
4IMAGE_INSTALL += "${PTESTS_FAST}"
5
6DESCRIPTION += "Also includes ptest packages with fast execution times to allow for more automated QA."
7
8# This image is sufficiently large (~1.8GB) that it can't actually fit in a live
9# image (which has a 4GB limit), so nullify the overhead factor (1.3x out of the
10# box) and explicitly add just 1500MB.
11# strace-ptest in particular needs more than 500MB
12IMAGE_OVERHEAD_FACTOR = "1.0"
13IMAGE_ROOTFS_EXTRA_SPACE = "1524288"
14
15# ptests need more memory than standard to avoid the OOM killer
16QB_MEM = "-m 1024"
Andrew Geissler82c905d2020-04-13 13:39:40 -050017
18# Sadly at the moment the fast set of ptests is not robust enough and sporadically fails in a couple of places
19PTEST_EXPECT_FAILURE = "1"