blob: c03f610da8dfc20a27e977f98cda1bfa835dc407 [file] [log] [blame]
Brad Bishop19323692019-04-05 15:28:33 -04001SUMMARY = "Meta-oe ptest packagegroups"
2
3inherit packagegroup
4
5PROVIDES = "${PACKAGES}"
6PACKAGES = ' \
Brad Bishop19323692019-04-05 15:28:33 -04007 packagegroup-meta-python3 \
8'
9
Brad Bishop19323692019-04-05 15:28:33 -040010RDEPENDS_packagegroup-meta-python3 = "\
11 packagegroup-meta-python3-extended \
12 packagegroup-meta-python3-connectivity \
13"
14
Brad Bishop19323692019-04-05 15:28:33 -040015RDEPENDS_packagegroup-meta-python3 = "\
16 python3-pyserial python3-gevent python3-alembic python3-robotframework-seriallibrary \
17 python3-rfc3987 python3-xlrd python3-bandit python3-constantly python3-inflection \
18 python3-javaobj-py3 python3-sh python3-pycrypto python3-pyasn1 python3-pydbus python3-wtforms \
19 python3-pybluez python3-babel python3-parse-type python3-bitarray python3-django-south \
20 python3-pyusb python3-prctl python3-jinja2 python3-werkzeug python3-pyjks python3-requests-ftp \
Andrew Geissler2ee498a2020-05-29 15:52:06 -050021 python3-behave python3-pyyaml python3-tzlocal python3-pretend python3-stevedore \
Brad Bishop19323692019-04-05 15:28:33 -040022 python3-sijax python3-langtable python3-requests-file python3-crcmod python3-robotframework \
23 python3-pint python3-coverage python3-iso8601 python3-ndg-httpsclient python3-yappi python3-twofish \
24 python3-speaklater python3-smbus python3-djangorestframework python3-msgpack python3-jsonpointer \
Andrew Geissler2ee498a2020-05-29 15:52:06 -050025 python3-flask-script python3-cassandra-driver python3-ujson python3-aws-iot-device-sdk-python \
26 python3-pytest-runner python3-pyiface python3-flask-login python3-markupsafe python3-setuptools-scm \
Brad Bishop19323692019-04-05 15:28:33 -040027 python3-semver python3-sdnotify python3-flask-user python3-tornado python3-jsonpatch python3-pexpect \
28 python3-progress python3-jsonschema python3-xstatic python3-pyroute2 python3-idna python3-sqlalchemy \
29 python3-urllib3 python3-flask-mail python3-asn1crypto python3-pyinotify python3-intervals python3-pyperclip \
30 python3-flask-bootstrap python3-pyudev python3-decorator python3-pybind11 python3-pluggy python3-redis \
31 python3-pycryptodome python3-passlib python3-dominate python3-ply python3-ntplib python3-serpent python3-wrapt \
32 python3-attrs python3-appdirs python3-isort python3-evdev python3-incremental python3-click python3-flask-nav \
33 python3-webcolors python3-dateutil python3-blinker python3-hyperlink python3-lxml python3-pylint \
34 python3-flask-migrate python3-pytest-tempdir python3-flask-restful python3-feedformatter \
35 python3-pyasn1-modules python3-scapy python3-html5lib python3-dnspython python3-automat \
36 python3-itsdangerous python3-pandas python3-pyfirmata python3-protobuf \
37 python3-flask-babel python3-anyjson python3-flask-xstatic python3-multidict python3-prompt-toolkit \
38 python3-periphery python3-greenlet python3-pytz python3-pyexpect python3-zopeinterface \
39 python3-bcrypt python3-xstatic-font-awesome python3-m2crypto python3-parse python3-attr \
40 python3-beautifulsoup4 python3-pycodestyle python3-oauthlib python3-grpcio python3-scrypt \
41 python3-pyjwt python3-astroid python3-flask-pymongo python3-wcwidth python3-lazy-object-proxy \
42 python3-websockets python3-pyzmq python3-pytest python3-chardet python3-vcversioner python3-whoosh \
43 python3-pymisp python3-certifi python3-psutil python3-flask-sqlalchemy python3-humanize \
44 python3-grpcio-tools python3-configparser python3-strict-rfc3339 python3-paho-mqtt \
45 python3-pytest-helpers-namespace python3-flask python3-flask-wtf python3-visitor python3-pynetlinux \
46 python3-requests python3-cryptography-vectors python3-spidev python3-pid python3-pymongo \
47 python3-future python3-django python3-unidiff python3-webencodings python3-can python3-pyalsaaudio \
48 python3-flask-sijax python3-cryptography python3-twisted python3-netaddr python3-pycparser \
49 python3-flask-uploads python3-pysocks python3-cffi python3-editor python3-ptyprocess \
50 python3-pyopenssl python3-ordered-set python3-simplejson python3-py \
51 ${@bb.utils.contains("DISTRO_FEATURES", "systemd", "python3-systemd", "", d)} \
52"
53
Brad Bishop19323692019-04-05 15:28:33 -040054RDEPENDS_packagegroup-meta-python3-extended = "\
55 python3-pykickstart \
56 python3-meh \
57 python3-blivet \
58 python3-pywbem \
59 python3-pyparted \
60 ${@bb.utils.contains("DISTRO_FEATURES", "x11", "python3-blivetgui", "", d)} \
61"
62
Brad Bishop19323692019-04-05 15:28:33 -040063RDEPENDS_packagegroup-meta-python3-connectivity = "\
64 python3-pytun \
65 python3-mprpc \
66 python3-pyconnman \
67 python3-gsocketpool \
68"
69
Brad Bishop19323692019-04-05 15:28:33 -040070RDEPENDS_packagegroup-meta-python3-ptest = "\
71 python3-cryptography \
72 "
73
74EXCLUDE_FROM_WORLD = "1"