blob: 94355b64d46df19f3e524d0bb9504c97ec5f1e28 [file] [log] [blame]
Brad Bishop6e60e8b2018-02-01 10:27:11 -05001SUMMARY = "download online streams into audio files"
2DESCRIPTION = "This command-line tool can be used to record MPEG III \
3and OGG online radio-streams into track-separated audio files."
4HOMEPAGE = "http://streamripper.sourceforge.net"
5LICENSE = "GPLv2"
6LIC_FILES_CHKSUM = "file://COPYING;md5=8ca43cbc842c2336e835926c2166c28b"
7DEPENDS = "glib-2.0 libmad libogg libvorbis"
8
9SRC_URI = "\
10 ${SOURCEFORGE_MIRROR}/${BPN}/${BP}.tar.gz \
11 file://0001-build-these-are-foreign-automake-projects.patch \
12 file://0002-build-don-t-ignore-CPPFLAGS-from-environment.patch \
13 file://0003-ripstream-fix-compilation.patch \
14"
15SRC_URI[mdsum] = "a37a1a8b8f9228522196a122a1c2dd32"
16SRC_URI[sha256sum] = "c1d75f2e9c7b38fd4695be66eff4533395248132f3cc61f375196403c4d8de42"
17
18inherit autotools pkgconfig
19
20EXTRA_OECONF += "--with-included-argv=yes --with-included-libmad=no"
21EXTRA_OECONF += "\
22 --with-ogg-includes=${STAGING_INCDIR} \
23 --with-ogg-libraries=${STAGING_LIBDIR} \
24 --with-vorbis-includes=${STAGING_INCDIR} \
25 --with-vorbis-libraries=${STAGING_LIBDIR} \
26"
27
28# the included argv library needs this
29CPPFLAGS_append = " -DANSI_PROTOTYPES"