blob: 1f390a4aa28064e5dcb250f52a4da894fb2959e0 [file] [log] [blame]
Brad Bishop19323692019-04-05 15:28:33 -04001SUMMARY = "Key/value database library with extensible hashing"
2HOMEPAGE = "http://www.gnu.org/software/gdbm/"
3SECTION = "libs"
4LICENSE = "GPLv3"
5LIC_FILES_CHKSUM = "file://COPYING;md5=241da1b9fe42e642cbb2c24d5e0c4d24"
6
7
8SRC_URI = "${GNU_MIRROR}/gdbm/gdbm-${PV}.tar.gz \
9 file://run-ptest \
10 file://ptest.patch \
11 "
12
Andrew Geisslerc723b722021-01-08 16:14:09 -060013SRC_URI[md5sum] = "aeb29c6a90350a4c959cd1df38cd0a7e"
14SRC_URI[sha256sum] = "37ed12214122b972e18a0d94995039e57748191939ef74115b1d41d8811364bc"
Brad Bishop19323692019-04-05 15:28:33 -040015
16inherit autotools gettext texinfo lib_package ptest
17
18# Needed for dbm python module
Andrew Geissler82c905d2020-04-13 13:39:40 -050019EXTRA_OECONF = "--enable-libgdbm-compat --without-readline"
Brad Bishop19323692019-04-05 15:28:33 -040020
21# Stop presence of dbm/nbdm on the host contaminating builds
22CACHED_CONFIGUREVARS += "ac_cv_lib_ndbm_main=no ac_cv_lib_dbm_main=no"
23
24BBCLASSEXTEND = "native nativesdk"
25
Brad Bishop19323692019-04-05 15:28:33 -040026do_install_append () {
27 # Create a symlink to ndbm.h and gdbm.h in include/gdbm to let other packages to find
28 # these headers
29 install -d ${D}${includedir}/gdbm
30 ln -sf ../ndbm.h ${D}/${includedir}/gdbm/ndbm.h
31 ln -sf ../gdbm.h ${D}/${includedir}/gdbm/gdbm.h
32}
33
34RDEPENDS_${PN}-ptest += "diffutils ${PN}-bin"
35
36do_compile_ptest() {
37 oe_runmake -C tests buildtests
38}
39
40PACKAGES =+ "${PN}-compat \
41 "
42FILES_${PN}-compat = "${libdir}/libgdbm_compat${SOLIBS} \
43 "