blob: 5dc4ab054efbab3df8ba4fdd97938132e98aed62 [file] [log] [blame]
Mohaimen Alsamaraif59d0172021-08-17 09:34:22 -05001FILESEXTRAPATHS:prepend:kudo := "${THISDIR}/${PN}:"
2RDEPENDS:${PN}:append:kudo = " bash"
Lancelot Kaodc456f92021-02-21 18:42:38 -06003
Charles Boyerc33f2352022-01-12 17:10:17 -06004OBMC_CONSOLE_TTYS = "ttyS1 ttyS3"
Lancelot Kaodc456f92021-02-21 18:42:38 -06005
Charles Boyerc33f2352022-01-12 17:10:17 -06006SRC_URI:append:kudo = " file://${BPN}@.service \
7 file://kudo_uart_mux_ctrl.sh \
8 "
Lancelot Kaodc456f92021-02-21 18:42:38 -06009
Mohaimen Alsamaraif59d0172021-08-17 09:34:22 -050010SYSTEMD_SERVICE:${PN}:append:kudo = " \
Charles Boyerc33f2352022-01-12 17:10:17 -060011 ${BPN}@.service \
Lancelot Kaodc456f92021-02-21 18:42:38 -060012 "
13
Mohaimen Alsamaraif59d0172021-08-17 09:34:22 -050014do_install:append() {
Lancelot Kaodc456f92021-02-21 18:42:38 -060015 # Overwrite base package's obmc-console@.service with our own
16 install -m 0644 ${WORKDIR}/${BPN}@.service ${D}${systemd_unitdir}/system/${BPN}@.service
Charles Boyer2adad362021-11-24 15:58:03 -060017 install -d ${D}${libexecdir}/${PN}
18 install -m 0755 ${WORKDIR}/kudo_uart_mux_ctrl.sh ${D}${libexecdir}/${PN}/kudo_uart_mux_ctrl.sh
Lancelot Kaodc456f92021-02-21 18:42:38 -060019}
20
Mohaimen Alsamaraif59d0172021-08-17 09:34:22 -050021pkg_postinst:${PN}:append () {
Lancelot Kaodc456f92021-02-21 18:42:38 -060022 systemctl --root=$D enable obmc-console@ttyS1.service
23 systemctl --root=$D enable obmc-console@ttyS3.service
24}
Charles Boyer2adad362021-11-24 15:58:03 -060025