blob: 307ee9b9813b3aeee14608296b28f39d5d1394e2 [file] [log] [blame]
Brad Bishop23eaf032019-11-20 05:15:02 -05001SUMMARY = "Simple web browser"
2DESCRIPTION = "Simple open source web browser based on WebKit2/GTK"
3HOMEPAGE = "https://surf.suckless.org/"
4SECTION = "x11/graphics"
5LICENSE = "MIT"
William A. Kennington IIIb95905d2021-06-02 12:40:56 -07006LIC_FILES_CHKSUM = "file://LICENSE;md5=2a6f86d002ae9ae1eb1ccc466289f146"
Brad Bishop23eaf032019-11-20 05:15:02 -05007
William A. Kennington IIIb95905d2021-06-02 12:40:56 -07008DEPENDS = "webkitgtk gtk+3 glib-2.0 gcr"
Brad Bishop23eaf032019-11-20 05:15:02 -05009
Brad Bishope42b3e32020-01-15 22:08:42 -050010REQUIRED_DISTRO_FEATURES = "x11 opengl"
Brad Bishop23eaf032019-11-20 05:15:02 -050011
12SRC_URI = "git://git.suckless.org/surf;branch=surf-webkit2 \
13 file://0001-config.mk-Fix-compiler-and-linker.patch \
14"
William A. Kennington IIIb95905d2021-06-02 12:40:56 -070015SRCREV = "bcd7d74e613fb8af11b40c351f0a6c1a771b2d2b"
Brad Bishop23eaf032019-11-20 05:15:02 -050016
17S = "${WORKDIR}/git"
18
Brad Bishop8410d612019-11-25 09:40:59 -050019inherit pkgconfig features_check
Brad Bishop23eaf032019-11-20 05:15:02 -050020
21TARGET_CC_ARCH += "${LDFLAGS}"
22
23do_install () {
24 install -D -m 0755 ${S}/surf ${D}${bindir}/surf
25}