blob: da168e2e841e534b14c1b40e4dd10bd54b00983d [file] [log] [blame]
Andrew Jeffery858c9712021-05-04 12:46:46 +09301SUMMARY = "Debug trigger"
2DESCRIPTION = "Forcibly crash an unresponsive system to collect debug data"
3HOMEPAGE = "https://github.com/openbmc/debug-trigger"
4
5SRC_URI = "git://github.com/openbmc/debug-trigger"
6
7LICENSE = "Apache-2.0"
8LIC_FILES_CHKSUM = "file://LICENSE;md5=e3fc50a88d0a364313df4b21ef20c29e"
9
10S = "${WORKDIR}/git"
11
12inherit meson
13inherit pkgconfig
14inherit systemd
15
16PR = "r1"
17PV = "0.1+git${SRCPV}"
18SRCREV = "20017150d229401edc9bbf33fa48ceba7f94db47"
19
20PACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'systemd', d)}"
21
22DEBUG_TRIGGERS ?= ""
23
24PACKAGECONFIG[systemd] = " \
25 -Dsystemd=true, \
26 -Dsystemd=false, \
27 systemd"
28
29PACKAGECONFIG[triggers] = " \
30 -Dtriggers=${DEBUG_TRIGGERS}, \
31 -Dtriggers=[], \
32 systemd udev"
33
34SYSTEMD_SERVICE_${PN} += "debug-trigger@.service"