blob: 9e959425f77bdc53d7b0aab47ee0b50dc5680f08 [file] [log] [blame]
Andrew Geissler595f6302022-01-24 19:11:47 +00001SUMMARY = "Provides a way to load and enumerate PKCS#11 modules"
2DESCRIPTION = " Provides a standard configuration setup for installing PKCS#11 modules in such a way that they're discoverable. Also solves problems with coordinating the use of PKCS#11 by different components or libraries living in the same process."
3HOMEPAGE = "https://p11-glue.github.io/p11-glue/p11-kit.html"
4LICENSE = "BSD-3-Clause"
5LIC_FILES_CHKSUM = "file://COPYING;md5=02933887f609807fbb57aa4237d14a50"
6
7inherit meson gettext pkgconfig gtk-doc bash-completion manpages
8
9DEPENDS = "libtasn1 libtasn1-native libffi"
10
11DEPENDS:append = "${@' glib-2.0' if d.getVar('GTKDOC_ENABLED') == 'True' else ''}"
12
Patrick Williamsda295312023-12-05 16:48:56 -060013SRC_URI = "gitsm://github.com/p11-glue/p11-kit;branch=master;protocol=https"
Patrick Williams169d7bc2024-01-05 11:33:25 -060014SRCREV = "917e02a3211dabbdea4b079cb598581dce84fda1"
Andrew Geissler595f6302022-01-24 19:11:47 +000015S = "${WORKDIR}/git"
16
17PACKAGECONFIG ??= ""
18PACKAGECONFIG[manpages] = "-Dman=true,-Dman=false,libxslt-native"
19PACKAGECONFIG[trust-paths] = "-Dtrust_paths=/etc/ssl/certs/ca-certificates.crt,,,ca-certificates"
20
21GTKDOC_MESON_OPTION = 'gtk_doc'
22
23FILES:${PN} += " \
24 ${libdir}/p11-kit-proxy.so \
25 ${libdir}/pkcs11/*.so \
26 ${libdir}/pkcs11/*.la \
27 ${systemd_user_unitdir}/*"
28
29# PN contains p11-kit-proxy.so, a symlink to a loadable module
30INSANE_SKIP:${PN} = "dev-so"
31
Andrew Geisslerc5535c92023-01-27 16:10:19 -060032BBCLASSEXTEND = "native nativesdk"