meta-security: subtree update:30ea7a89dc..d75dc96fa3

Armin Kuster (11):
      python-scapy: drop py2 package
      packagegroup-core-security-ptest: only included if ptest is enabled
      packagegroup-core-security: update package name
      busybox: fix sig changes when layer added
      initramfs-framework-ima: correct IMA_POLICY name
      apparmor: drop lsb RDEPENDS
      openscap: Drop nostamp
      scap-security-guide: add depends on openscap-native do_install
      cryptsetup-tpm-incubator: fix QA error RDEPENDS
      oe-scap: Fix QA RDEPENDS error
      suricata: update to 4.1.4

Stefan Agner (1):
      libseccomp: build static library always

Change-Id: Ia2f8aec978de4f3d20c13be3c12b70a7badc29d5
Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
diff --git a/meta-security/recipes-security/packagegroup/packagegroup-core-security-ptest.bb b/meta-security/recipes-security/packagegroup/packagegroup-core-security-ptest.bb
index ddcf208..39873b8 100644
--- a/meta-security/recipes-security/packagegroup/packagegroup-core-security-ptest.bb
+++ b/meta-security/recipes-security/packagegroup/packagegroup-core-security-ptest.bb
@@ -3,6 +3,10 @@
 LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/MIT;md5=0835ade698e0bcf8506ecda2f7b4f302 \
                     file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
 
+inherit distro_features_check
+
+REQUIRED_DISTRO_FEATURES = "ptest"
+
 PACKAGES = "\
     ${PN} \
     "
@@ -15,7 +19,7 @@
     samhain-standalone-ptest \
     keyutils-ptest \
     libseccomp-ptest \
-    python-scapy-ptest \
+    python3-scapy-ptest \
     suricata-ptest \
     tripwire-ptest \
     python-fail2ban-ptest \