meta-yadro: vesnin: new YAML dependency scheme

All the IPMI virtuals and PREFERRED_PROVIDERS in meta-phosphor are in
the process of being deprecated.  Prepare for that and move to a simpler
scheme for providing the YAML configuration for Vesnin systems.

(From meta-yadro rev: 9c29d1b377aafa400444273bfb7fdd28b0803f34)

Change-Id: Id243bb4e0f2c742ebb1124195a16b9ce20856091
Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
diff --git a/meta-yadro/meta-vesnin/recipes-phosphor/configuration/vesnin-yaml-config.bb b/meta-yadro/meta-vesnin/recipes-phosphor/configuration/vesnin-yaml-config.bb
new file mode 100644
index 0000000..dc786e5
--- /dev/null
+++ b/meta-yadro/meta-vesnin/recipes-phosphor/configuration/vesnin-yaml-config.bb
@@ -0,0 +1,23 @@
+SUMMARY = "YAML configuration for Vesnin"
+PR = "r1"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://${YADROBASE}/COPYING.apache-2.0;md5=34400b68072d710fecd0a2940a0d1658"
+
+inherit allarch
+
+SRC_URI = " \
+    file://vesnin-ipmi-fru.yaml \
+    "
+
+S = "${WORKDIR}"
+
+do_install() {
+    install -m 0644 -D vesnin-ipmi-fru.yaml \
+        ${D}${datadir}/${BPN}/ipmi-fru-read.yaml
+}
+
+FILES_${PN}-dev = " \
+    ${datadir}/${BPN}/ipmi-fru-read.yaml \
+    "
+
+ALLOW_EMPTY_${PN} = "1"