meta-phosphor: Fix explicit dependencies antipattern
Out of the box bitbake examines built applications, automatically adds
runtime dependencies and thus ensures any library packages dependencies
are automatically added to images, sdks, etc. There is no need to list
them explicitly in a recipe.
Dependencies change over time, and listing them explicitly is likely
prone to errors - the net effect being unnecessary shared library
packages being installed into images.
Consult
https://www.yoctoproject.org/docs/latest/mega-manual/mega-manual.html#var-RDEPENDS
for information on when to use explicit runtime dependencies.
(From meta-phosphor rev: 26873c99d30b55e21a920c9851f21c3e2eab19f7)
Change-Id: I38640d75a2d834c07d45ddcdb0162f1a23f848d9
Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
diff --git a/meta-phosphor/recipes-phosphor/fans/obmc-control-fan_git.bb b/meta-phosphor/recipes-phosphor/fans/obmc-control-fan_git.bb
index ef49a43..e7d86e4 100644
--- a/meta-phosphor/recipes-phosphor/fans/obmc-control-fan_git.bb
+++ b/meta-phosphor/recipes-phosphor/fans/obmc-control-fan_git.bb
@@ -7,7 +7,8 @@
inherit obmc-phosphor-dbus-service
inherit pkgconfig
-RDEPENDS_${PN} += "libsystemd"
+DEPENDS = "systemd"
+
SKELETON_DIR = "fanctl"
DBUS_SERVICE_${PN} += "org.openbmc.control.Fans.service"