Initial recipe for FFDC tarball script
Delivers a command line tool for collection
of debug data.
Change-Id: I37862b2b100e7fb3445447bd1a7ebc5884813eec
Signed-off-by: Michael Tritz <mtritz@us.ibm.com>
diff --git a/meta-phosphor/common/recipes-phosphor/logging/ffdc.bb b/meta-phosphor/common/recipes-phosphor/logging/ffdc.bb
new file mode 100644
index 0000000..816073b
--- /dev/null
+++ b/meta-phosphor/common/recipes-phosphor/logging/ffdc.bb
@@ -0,0 +1,22 @@
+SUMMARY = "FFDC collector script"
+DESCRIPTION = "Command line tool to collect and tar up debug data"
+PR = "r1"
+
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://${S}/LICENSE;md5=<checksum>"
+
+RDEPENDS_${PN} += " \
+ systemd \
+ ${VIRTUAL-RUNTIME_base-utils} \
+ "
+
+S = "${WORKDIR}"
+SRC_URI += "git://github.com/openbmc/phosphor-debug-collector/"
+
+SRCREV = "3e3f28b4fbeada4b3f254d1b2d836c5fcb0bc28f"
+
+do_install() {
+ install -d ${D}${bindir}
+ install -m 0755 ffdc \
+ ${D}${bindir}/ffdc
+}