meta-openembedded: subtree update:a2928764c2..19528ba2a6
Adrian Bunk (1):
libqmi: Replace clang patch with configure option
Bartosz Golaszewski (3):
yad: new package
zenity: new package
unclutter-xfixes: new package
Khem Raj (2):
mycroft: Remove alsa-oss from rdeps
bigbuckbunny: Use faster download mirrors
Oleksandr Kravchuk (21):
capnproto: update to 0.7.0
ddrescue: update to 1.24
fmt: update to 6.0.0
jsonrpc: update to 1.2.0
libburn: update to 1.5.0
libdvdread: update to 6.0.1
libev: update to 4.27
libmodplug: update to 0.8.9.0
libnice: update to 0.1.16
libopus: update to 1.3.1
libsass: update to 3.6.1
libuv: update to 1.32.0
libsocketcan: update to 0.0.11
tree: update to 1.8.0
xclock: update to 1.0.9
xcursorgen: update to 1.0.7
xfontsel: update to 1.0.6
xmag: update to 1.0.6
xmessage: update to 1.0.5
xorg-sgml-doctools: update to 1.11
evtest: update to 1.34
Peiran Hong (1):
tcpdump: Fix CVE-2017-16808
Change-Id: I4f2f575382cd34404d10470ece0aae7620487902
Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
diff --git a/meta-openembedded/meta-oe/recipes-support/tree/tree_1.8.0.bb b/meta-openembedded/meta-oe/recipes-support/tree/tree_1.8.0.bb
new file mode 100644
index 0000000..01b1ac3
--- /dev/null
+++ b/meta-openembedded/meta-oe/recipes-support/tree/tree_1.8.0.bb
@@ -0,0 +1,21 @@
+SUMMARY = "A recursive directory listing command"
+HOMEPAGE = "http://mama.indstate.edu/users/ice/tree/"
+SECTION = "console/utils"
+LICENSE = "GPLv2"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=393a5ca445f6965873eca0259a17f833"
+
+SRC_URI = "http://mama.indstate.edu/users/ice/tree/src/${BP}.tgz"
+SRC_URI[md5sum] = "715191c7f369be377fc7cc8ce0ccd835"
+SRC_URI[sha256sum] = "715d5d4b434321ce74706d0dd067505bb60c5ea83b5f0b3655dae40aa6f9b7c2"
+
+# tree's default CFLAGS for Linux
+CFLAGS += "-Wall -DLINUX -D_LARGEFILE64_SOURCE -D_FILE_OFFSET_BITS=64"
+
+EXTRA_OEMAKE = "CC='${CC}' CFLAGS='${CFLAGS}' LDFLAGS='${LDFLAGS}'"
+
+do_configure[noexec] = "1"
+
+do_install() {
+ install -d ${D}${bindir}
+ install -m 0755 ${S}/${BPN} ${D}${bindir}/
+}