meta-openembedded: subtree update:3a9262866d..55de2d06ad
Adrian Bunk (1):
python-more-itertools: Add PE
Andreas Müller (1):
Add gnome help packages to image according to IMAGE_LINGUAS
Andreas Oberritter (2):
live555: Move test progams out of main package
pugixml: Update to version 1.10
André Draszik (7):
gyp: update to fcd686f1880f
gyp: provide a python2 version of gyp as gyp-py2
nodejs: ensure to use correct compiler & flags always
nodejs: delete all bundled deps in do_unpack() if needed
nodejs: allow use of system gyp
nodejs: use OE-provided compiler flags (arm)
nodejs: support long directory names for ${B} / ${S}
Denys Dmytriyenko (1):
mbedtls: upgrade 2.16.2 -> 2.16.3
Fabio Berton (5):
python-importlib-metadata: Add native and nativesdk to BBCLASSEXTEND
python-more-itertools: Add native and nativesdk to BBCLASSEXTEND
python-pathlib2: Add native and nativesdk to BBCLASSEXTEND
python-zipp: Add native and nativesdk to BBCLASSEXTEND
python3-importlib-metadata: RDEPEND python3-misc only for target and nativesdk
Khem Raj (13):
sip: Upgrade to 4.19.19
cherokee: Update to latest
cherokee: Fix build when time_t is 64bit
tvheadend: Update to tip of master
lowpan-tools: Blacklist as its deprecated use wpan-tools instead
pidgin-sipe: Fix build when time_t is 64bit
open-vm-tools: Enable tirpc explicitly, fix build with 64bit time_t
python-systemd: Include endian.h for htobe16
tvheadend: Fix build with 64bit time_t
tvheadend: Set CLEANBROKEN
layer.conf: Add ttf-roboto->fontconfig to SIGGEN_EXCLUDE_SAFE_RECIPE_DEPS
layer.conf: Add phpmyadmin->php dep to SIGGEN_EXCLUDE_SAFE_RECIPE_DEPS
python-six: Update to 1.13.0
Michael Scott (1):
modemmanager: Upgrade 1.10.6 -> 1.10.8
Nicola Lunghi (5):
python3-gmqtt: add recipe
python-backports-abc: update to 0.5.0
python-rfc3339-validator: add recipe
python-rfc3986-validator: add recipe
python-dbus-next: fix recipe position
Peace Lee (1):
guider: upgrade 3.9.4 -> 3.9.6
Trevor Gamblin (4):
python3-werkzeug: upgrade from 0.14.1 to 0.16.0
python3-flask: upgrade from 1.0.2 to 1.1.1
python3-itsdangerous: upgrade from 0.24 to 1.1.0
zabbix: upgrade 4.2.8 -> 4.4.1
Yi Zhao (1):
python-ipy: add recipes
Zang Ruochen (15):
fuse3: upgrade 3.7.0 -> 3.8.0
python-alembic: upgrade 1.2.1 -> 1.3.0
python-astroid: upgrade 2.3.2 -> 2.3.3
python-bitarray: upgrade 1.0.1 -> 1.1.0
python-cffi: upgrade 1.13.1 -> 1.13.2
python-dateutil: upgrade 2.8.0 -> 2.8.1
python-psutil: upgrade 5.6.3 -> 5.6.5
python-pycryptodome: upgrade 3.9.0 -> 3.9.3
python-pyparsing: upgrade 2.4.2 -> 2.4.5
python-pytest-helpers-namespace: upgrade 2016.7.10 -> 2019.1.8
python-pytest-runner: upgrade 5.1 -> 5.2
python-pytest-tempdir: upgrade 2016.8.20 -> 2019.10.12
python-requests-oauthlib: upgrade 0.8.0 -> 1.3.0
python-tornado: upgrade 5.1 -> 6.0.3
python-tqdm: upgrade 4.31.1 -> 4.38.0
Zheng Ruoqin (1):
f2fs-tools: Update Homepage
Change-Id: Ifc2d7bac36a719f2a4ead82b491d9817f212c56f
Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
diff --git a/meta-openembedded/meta-oe/recipes-connectivity/zabbix/zabbix_4.4.1.bb b/meta-openembedded/meta-oe/recipes-connectivity/zabbix/zabbix_4.4.1.bb
new file mode 100644
index 0000000..656ff0d
--- /dev/null
+++ b/meta-openembedded/meta-oe/recipes-connectivity/zabbix/zabbix_4.4.1.bb
@@ -0,0 +1,78 @@
+SUMMARY = "Open-source monitoring solution for your IT infrastructure"
+DESCRIPTION = "\
+ZABBIX is software that monitors numerous parameters of a network and the \
+health and integrity of servers. ZABBIX uses a flexible notification \
+mechanism that allows users to configure e-mail based alerts for virtually \
+any event. This allows a fast reaction to server problems. ZABBIX offers \
+excellent reporting and data visualisation features based on the stored \
+data. This makes ZABBIX ideal for capacity planning. \
+\
+ZABBIX supports both polling and trapping. All ZABBIX reports and \
+statistics, as well as configuration parameters are accessed through a \
+web-based front end. A web-based front end ensures that the status of \
+your network and the health of your servers can be assessed from any \
+location. Properly configured, ZABBIX can play an important role in \
+monitoring IT infrastructure. This is equally true for small \
+organisations with a few servers and for large companies with a \
+multitude of servers."
+HOMEPAGE = "http://www.zabbix.com/"
+SECTION = "Applications/Internet"
+LICENSE = "GPLv2+"
+LIC_FILES_CHKSUM = "file://COPYING;md5=300e938ad303147fede2294ed78fe02e"
+DEPENDS = "libevent libpcre openldap virtual/libiconv zlib"
+
+PACKAGE_ARCH = "${MACHINE_ARCH}"
+
+SRC_URI = "http://jaist.dl.sourceforge.net/project/zabbix/ZABBIX%20Latest%20Stable/${PV}/${BPN}-${PV}.tar.gz \
+ file://0001-Fix-configure.ac.patch \
+ file://zabbix-agent.service \
+"
+
+SRC_URI[md5sum] = "e9df94149790f86732f18d042b70155d"
+SRC_URI[sha256sum] = "0bf74e597dd41a558305fe17a2b1ed6fe2d77044b87696a92e4227fbf315564a"
+
+inherit autotools-brokensep linux-kernel-base pkgconfig systemd useradd
+
+SYSTEMD_PACKAGES = "${PN}"
+SYSTEMD_SERVICE_${PN} = "zabbix-agent.service"
+SYSTEMD_AUTO_ENABLE = "enable"
+
+USERADD_PACKAGES = "${PN}"
+GROUPADD_PARAM_${PN} = "-r zabbix"
+USERADD_PARAM_${PN} = "-r -g zabbix -d /var/lib/zabbix \
+ -s /sbin/nologin -c \"Zabbix Monitoring System\" zabbix \
+"
+
+KERNEL_VERSION = "${@get_kernelversion_headers('${STAGING_KERNEL_DIR}')}"
+
+EXTRA_OECONF = " \
+ --enable-dependency-tracking \
+ --enable-agent \
+ --enable-ipv6 \
+ --with-net-snmp \
+ --with-ldap=${STAGING_EXECPREFIXDIR} \
+ --with-unixodbc \
+ --with-ssh2 \
+ --with-sqlite3 \
+ --with-zlib \
+ --with-libpthread \
+ --with-libevent \
+ --with-libpcre \
+"
+CFLAGS_append = " -lldap -llber -pthread"
+
+do_configure_prepend() {
+ export KERNEL_VERSION="${KERNEL_VERSION}"
+}
+
+do_install_append() {
+ if ${@bb.utils.contains('DISTRO_FEATURES','systemd','true','false',d)}; then
+ install -d ${D}${systemd_unitdir}/system
+ install -m 0644 ${WORKDIR}/zabbix-agent.service ${D}${systemd_unitdir}/system/
+ sed -i -e 's#@SBINDIR@#${sbindir}#g' ${D}${systemd_unitdir}/system/zabbix-agent.service
+ fi
+}
+
+FILES_${PN} += "${libdir}"
+
+RDEPENDS_${PN} = "logrotate"