meta-openembedded: subtree update:18506b797b..c986cbed93

Adrian Bunk (7):
      gpsd: Backport a memory leak fix
      gpsd: Stop depending on chrpath-native
      klibc: Upgrade 2.0.6 -> 2.0.7
      gerbera: Upgrade 1.3.0 -> 1.3.2
      gstd: Fix the version number
      webrtc-audio-processing: Upgrade 0.3 -> 0.3.1
      vlc: Upgrade 3.0.6 -> 3.0.8

Andreas Müller (15):
      itstool: rework native shebang and add class to make native itstool work
      yelp-tools: use itstools.bbclass
      yelp-xsl: use itstool.bbclass
      yelp: use itstool.bbclass
      gnome-help.bbclass: Handle gnome-help files with new distro feature 'helpfiles'
      zenity: rework recipe
      dconf: extend to native build for upcoming gdm
      dconf-editor: upgrade 3.32.0 -> 3.34.0
      gtksourceview4: upgrade 4.2.0 -> 4.4.0
      gnome-menus3: upgrade 3.10.1 -> 3.32.0
      gnome-desktop3: upgrade 3.34.0 -> 3.34.1
      gnome-bluetooth: upgrade 3.32.1 -> 3.34.0
      gspell: upgrade 1.8.1 -> 1.8.2
      gnome-system-monitor: upgrade 3.32.0 -> 3.32.1
      network-manager-applet: upgrade 1.8.22 -> 1.8.23 / build with meson / cleanup

Luca Boccassi (4):
      dbus-broker: 19 -> 21
      dbus-broker: backport patches from master
      dbus-broker: build with SELinux if it's enabled via DISTRO_FEATURES
      dbus-broker: add patch to fix build with musl libc

Trevor Gamblin (1):
      rsyslog: upgrade from v8.1908.0 to v8.1910.0

Zang Ruochen (4):
      python-bitarray: upgrade 0.8.3 -> 1.0.1
      python-can: upgrade 2.2.1 -> 3.3.2
      python-daemonize: upgrade 2.4.7 -> 2.5.0
      xmlsec1: upgrade 1.2.28 -> 1.2.29

Zheng Ruoqin (2):
      keepalived: upgrade 2.0.16 -> 2.0.19
      postfix: upgrade 3.4.5 -> 3.4.7

Change-Id: Ibff272f163bb42473022825cfb17a284a0019e83
Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
diff --git a/meta-openembedded/meta-oe/recipes-support/xmlsec1/xmlsec1_1.2.29.bb b/meta-openembedded/meta-oe/recipes-support/xmlsec1/xmlsec1_1.2.29.bb
new file mode 100644
index 0000000..40c585e
--- /dev/null
+++ b/meta-openembedded/meta-oe/recipes-support/xmlsec1/xmlsec1_1.2.29.bb
@@ -0,0 +1,64 @@
+SUMMARY = "XML Security Library is a C library based on LibXML2"
+DESCRIPTION = "\
+    XML Security Library is a C library based on \
+    LibXML2 and OpenSSL. The library was created with a goal to support major \
+    XML security standards "XML Digital Signature" and "XML Encryption". \
+    "
+HOMEPAGE = "http://www.aleksey.com/xmlsec/"
+DEPENDS = "libtool libxml2 libxslt zlib"
+
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://COPYING;md5=352791d62092ea8104f085042de7f4d0"
+
+SECTION = "libs"
+
+SRC_URI = "http://www.aleksey.com/xmlsec/download/${BP}.tar.gz \
+    file://fix-ltmain.sh.patch \
+    file://change-finding-path-of-nss.patch \
+    file://makefile-ptest.patch \
+    file://xmlsec1-examples-allow-build-in-separate-dir.patch \
+    file://run-ptest \
+    "
+
+SRC_URI[md5sum] = "4755621ff2a7150e208de6bd7decca10"
+SRC_URI[sha256sum] = "b1d1deba966019930f608d1f2b95c40ca3450f1393bcd3a3c001a8ba1d2839ab"
+
+inherit autotools-brokensep ptest pkgconfig
+
+CFLAGS += "-I${STAGING_INCDIR}/nspr4 -I${STAGING_INCDIR}/nss3"
+CPPFLAGS += "-I${STAGING_INCDIR}/nspr4 -I${STAGING_INCDIR}/nss3"
+
+PACKAGECONFIG ??= "gnutls libgcrypt nss openssl des"
+PACKAGECONFIG[gnutls] = ",,gnutls"
+PACKAGECONFIG[libgcrypt] = ",,libgcrypt"
+PACKAGECONFIG[nss] = "--with-nss=${STAGING_LIBDIR}/../.. --with-nspr=${STAGING_LIBDIR}/../..,,nss nspr"
+PACKAGECONFIG[openssl] = ",,openssl"
+PACKAGECONFIG[des] = ",--disable-des,,"
+
+# these can be dynamically loaded with xmlSecCryptoDLLoadLibrary()
+FILES_SOLIBSDEV = "${libdir}/libxmlsec1.so"
+FILES_${PN} += "${libdir}/libxmlsec1-*.so"
+INSANE_SKIP_${PN} = "dev-so"
+
+FILES_${PN}-dev += "${libdir}/xmlsec1Conf.sh"
+FILES_${PN}-dbg += "${PTEST_PATH}/.debug/*"
+
+RDEPENDS_${PN}-ptest += "${PN}-dev"
+INSANE_SKIP_${PN}-ptest += "dev-deps"
+
+PTEST_EXTRA_ARGS = "top_srcdir=${S} top_builddir=${B}"
+
+do_compile_ptest () {
+    oe_runmake -C ${S}/examples ${PTEST_EXTRA_ARGS} all
+}
+
+do_install_append() {
+    for i in ${bindir}/xmlsec1-config ${libdir}/xmlsec1Conf.sh \
+        ${libdir}/pkgconfig/xmlsec1-openssl.pc; do
+        sed -i -e "s@${RECIPE_SYSROOT}@@g" ${D}$i
+    done
+}
+
+do_install_ptest () {
+    oe_runmake -C ${S}/examples DESTDIR=${D}${PTEST_PATH} ${PTEST_EXTRA_ARGS} install-ptest
+}