poky: refresh thud: 1d987b98ed..ee7dd31944
Update poky to thud HEAD.
Alex Kiernan (2):
systemd: backport fix to stop enabling ECN
systemd: Add PACKAGECONFIG for gnutls
Alexander Kanavin (3):
lighttpd: update to 1.4.51
boost: update to 1.69.0
systemd: backport a patch to fix meson 0.49.0 issue
Alexey Brodkin (1):
wic: sdimage-bootpart: Use mmcblk0 drive instead of bogus mmcblk
André Draszik (1):
meta: remove True option to getVar calls (again)
Anuj Mittal (6):
eudev: upgrade 3.2.5 -> 3.2.7
gsettings-desktop-schemas: upgrade 3.28.0 -> 3.28.1
libatomic-ops: upgrade 7.6.6 -> 7.6.8
libpng: upgrade 1.6.35 -> 1.6.36
common-licenses: update Libpng license text
i2c-tools: upgrade 4.0 -> 4.1
Aníbal Limón (1):
meta/classes/testimage.bbclass: Only validate IMAGE_FSTYPES when is QEMU
Armin Kuster (1):
tzdata/tzcode-native: update to 2018i
Brad Bishop (1):
systemd-systemctl-native: handle Install wildcards
Bruce Ashfield (3):
kernel: use olddefconfig as the primary target for KERNEL_CONFIG_COMMAND
linux-yocto/4.18: update to v4.18.22
linux-yocto/4.18: update to v4.18.25
Changqing Li (1):
libsndfile1: Security fix CVE-2017-17456/17457 CVE-2018-19661/19662
Chen Qi (3):
package.bbclass: fix python unclosed file ResourceWarning
eSDK.py: avoid error in tearDownClass due to race condistion
eSDK.py: unset BBPATH and BUILDDIR to avoid eSDK failure
Douglas Royds (6):
icecc: readlink -f on the recipe-sysroot gcc/g++
icecc: Trivial simplification
icecc: Syntax error meant that we weren't waiting for tarball generation
icecc: Don't generate recipe-sysroot symlinks at recipe-parsing time
icecc: patchelf is needed by icecc-create-env
patch: reproducibility: Fix host umask leakage
Erik Botö (1):
testimage: Add possibility to pass parmeters to qemu
Federico Sauter (1):
kernel: don't assign the build user/host
Joshua Watt (1):
classes/testsdk: Split implementation into classes
Kai Kang (2):
testimage.bbclass: remove boot parameter systemd.log_target
systemd: fix compile error for x32
Kevin Hao (1):
meta-yocto-bsp: Bump to the latest stable kernel for the non-x86 BSPs
Khem Raj (6):
grub2: Fix passing null to printf formats
gnupg: Upgrade to 2.2.12 release
binutils: Fix build with clang
binutils: Upgrade to latest on 2.31 release branch
binutils: bfd doesn't handle ELF compressed data alignment
systemd: Fix memory use after free errors
Manjukumar Matha (1):
kernel.bbclass: Fix incorrect deploying of fitimage.initramfs
Marcus Cooper (3):
systemd: Security fix CVE-2018-16864
systemd: Security fix CVE-2018-16865
systemd: Security fix CVE-2018-16866
Michael Ho (1):
sstate: add support for caching shared workdir tasks
Naveen Saini (2):
linux-yocto: update genericx86* SRCREV for 4.18
linux-yocto: update genericx86* SRCREV for 4.18
Peter Kjellerstedt (2):
systemd: Correct and clean up user/group definitions
systemd: Correct a conditional add to SYSTEMD_PACKAGES
Richard Purdie (9):
nativesdk-*-provides-dummy: Fixes to allow correct operation with opkg
classes: Correctly markup regex strings
testimage: Remove duplicate dependencies
testimage: Simplfy DEFAULT_TEST_SUITES logic
testimage: Further cleanup DEFAULT_TEST_SUITES
testimage: Enable autorunning of the package manager testsuites
oeqa/runtime/cases: Improve test dependency information
oeqa/runtime/cases: Improve dependencies of kernel/gcc/build tests
oeqa/utils/buildproject: Only clean files if we've done something
Robert Yang (7):
oeqa/utils/qemurunner: Print output when failed to login
oeqa/utils/qemurunner: set timeout to 60s for run_serial
oeqa: Fix for QEMU_USE_KVM
oeqa: make it work for multiple users
runqemu-gen-tapdevs: Allow run --help without sudo
oeqa/manual/bsp-qemu.json: Update for QEMU_USE_KVM
oeqa/selftest/runqemu: Enable kvm when QEMU_USE_KVM is set
Ross Burton (2):
toolchain-scripts: run post-relocate scripts for every environment
runqemu: clean up subprocess usage
Yeoh Ee Peng (3):
scripts/oe-git-archive: fix non-existent key referencing error
testimage: Add support for slirp
oeqa/qemu & runtime: qemu do not need ip input from external
OpenBMC compatibility updates:
meta-phosphor:
Brad Bishop (1):
phosphor: rebase i2c-tools patches
Change-Id: Idc626fc076580aeebde1420bcad01e069b559504
Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
diff --git a/poky/meta/classes/insane.bbclass b/poky/meta/classes/insane.bbclass
index 6718feb..295feb8 100644
--- a/poky/meta/classes/insane.bbclass
+++ b/poky/meta/classes/insane.bbclass
@@ -111,7 +111,7 @@
phdrs = elf.run_objdump("-p", d)
import re
- rpath_re = re.compile("\s+RPATH\s+(.*)")
+ rpath_re = re.compile(r"\s+RPATH\s+(.*)")
for line in phdrs.split("\n"):
m = rpath_re.match(line)
if m:
@@ -140,7 +140,7 @@
phdrs = elf.run_objdump("-p", d)
import re
- rpath_re = re.compile("\s+RPATH\s+(.*)")
+ rpath_re = re.compile(r"\s+RPATH\s+(.*)")
for line in phdrs.split("\n"):
m = rpath_re.match(line)
if m:
@@ -203,8 +203,8 @@
# The re's are purposely fuzzy, as some there are some .so.x.y.z files
# that don't follow the standard naming convention. It checks later
# that they are actual ELF files
- lib_re = re.compile("^/lib.+\.so(\..+)?$")
- exec_re = re.compile("^%s.*/lib.+\.so(\..+)?$" % exec_prefix)
+ lib_re = re.compile(r"^/lib.+\.so(\..+)?$")
+ exec_re = re.compile(r"^%s.*/lib.+\.so(\..+)?$" % exec_prefix)
for root, dirs, files in os.walk(pkgdest):
if root == pkgdest:
@@ -302,7 +302,7 @@
# Check the architecture and endiannes of the binary
is_32 = (("virtual/kernel" in provides) or bb.data.inherits_class("module", d)) and \
(target_os == "linux-gnux32" or target_os == "linux-muslx32" or \
- target_os == "linux-gnu_ilp32" or re.match('mips64.*32', d.getVar('DEFAULTTUNE')))
+ target_os == "linux-gnu_ilp32" or re.match(r'mips64.*32', d.getVar('DEFAULTTUNE')))
is_bpf = (oe.qa.elf_machine_to_string(elf.machine()) == "BPF")
if not ((machine == elf.machine()) or is_32 or is_bpf):
package_qa_add_message(messages, "arch", "Architecture did not match (%s, expected %s) on %s" % \
@@ -342,7 +342,7 @@
sane = True
import re
- textrel_re = re.compile("\s+TEXTREL\s+")
+ textrel_re = re.compile(r"\s+TEXTREL\s+")
for line in phdrs.split("\n"):
if textrel_re.match(line):
sane = False
@@ -952,7 +952,7 @@
import re
# The package name matches the [a-z0-9.+-]+ regular expression
- pkgname_pattern = re.compile("^[a-z0-9.+-]+$")
+ pkgname_pattern = re.compile(r"^[a-z0-9.+-]+$")
taskdepdata = d.getVar("BB_TASKDEPDATA", False)
taskdeps = set()
@@ -1160,7 +1160,7 @@
if pn in overrides:
msg = 'Recipe %s has PN of "%s" which is in OVERRIDES, this can result in unexpected behaviour.' % (d.getVar("FILE"), pn)
package_qa_handle_error("pn-overrides", msg, d)
- prog = re.compile('[A-Z]')
+ prog = re.compile(r'[A-Z]')
if prog.search(pn):
package_qa_handle_error("uppercase-pn", 'PN: %s is upper case, this can result in unexpected behavior.' % pn, d)