Use openpower-proc-control in bitbake

The executable built from this repository will now be
used in start_host@.service and vcs_workaround@.service
instead of the shell scripts that use pdbg to do FSI commands.

Change-Id: I8ef3075449b562d64295ae330bd2c150264a0607
Signed-off-by: Matt Spinler <spinler@us.ibm.com>
diff --git a/meta-openbmc-machines/meta-openpower/common/recipes-phosphor/host/op-proc-control.bb b/meta-openbmc-machines/meta-openpower/common/recipes-phosphor/host/op-proc-control.bb
new file mode 100644
index 0000000..0999c82
--- /dev/null
+++ b/meta-openbmc-machines/meta-openpower/common/recipes-phosphor/host/op-proc-control.bb
@@ -0,0 +1,16 @@
+SUMMARY = "OpenPower procedure control"
+DESCRIPTION = "Provides procedures that run against the host chipset"
+PR = "r1"
+
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=e3fc50a88d0a364313df4b21ef20c29e"
+
+S = "${WORKDIR}/git"
+
+inherit autotools pkgconfig
+
+DEPENDS += "autoconf-archive-native phosphor-logging"
+RDEPENDS_${PN} += "phosphor-logging"
+
+SRC_URI += "git://github.com/openbmc/openpower-proc-control"
+SRCREV = "0c0eeff6e991077f6a4570880b01396ac1b9e2e5"