meta-openembedded: subtree update:19528ba2a6..ef1b17f4ef

Callaghan, Dan (1):
      lmsensors: add a PACKAGECONFIG for sensord

Changqing Li (1):
      ntp: fix package split wrongly when enabled usrmerge

Khem Raj (1):
      remove spurious file

Nathan Rossi (3):
      libeigen: Add native and nativesdk to BBCLASSEXTEND
      python*-pyusb: Add native and nativesdk to BBCLASSEXTEND
      python*-pyserial: Add native and nativesdk to BBCLASSEXTEND

Oleksandr Kravchuk (23):
      babl: update to 0.1.62
      znc: update to 1.7.4
      zlog: update to 1.2.14
      wipe: update to 0.24
      upower: update to 0.99.11
      python-pyobject: update to 3.34.0
      python-pytoml: update to 0.1.21
      python-cpuset: update to 1.6
      libwebsockets: update to 3.2.0
      libvpx: update to 1.8.1
      libvdpau: update to 1.3
      libmicrohttpd: update to 0.9.66
      lcms: update to 2.9
      libblockdev: update to 2.23
      libbytesize: update to 2.1
      iwd: update to 0.20
      gsl: update to 2.6
      gflags: update to 2.2.2
      digitemp: update to 3.7.2
      catch2: update to 2.9.2
      botan: update to 2.11.0
      agent-proxy: update to 1.97
      ceres-solver: fix package version

Paul Eggleton (1):
      mosquitto: update to 1.6.5

Scott Ellis (1):
      wireguard: Upgrade 20190905 to 20190913

Trevor Gamblin (1):
      openjpeg: upgrade 2.3.0 -> 2.3.1

Yi Zhao (1):
      samba: upgrade 4.10.7 -> 4.10.8

Zang Ruochen (2):
      python-dbus: upgrade 1.2.10 -> 1.2.12
      python-pluggy: upgrade 0.12.0 -> 0.13.0

Zheng Ruoqin (1):
      xrdp: 0.9.4 -> 0.9.11

Change-Id: I3152060569cc5af7f7950c7037f25f54191d20a9
Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
diff --git a/meta-openembedded/meta-networking/recipes-irc/znc/znc_1.7.4.bb b/meta-openembedded/meta-networking/recipes-irc/znc/znc_1.7.4.bb
new file mode 100644
index 0000000..7586007
--- /dev/null
+++ b/meta-openembedded/meta-networking/recipes-irc/znc/znc_1.7.4.bb
@@ -0,0 +1,32 @@
+SUMMARY = "ZNC, an advanced IRC bouncer"
+SECTION = "net"
+LICENSE = "GPLv2"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57"
+
+DEPENDS = "openssl zlib icu"
+
+SRC_URI = "git://github.com/znc/znc.git;name=znc \
+           git://github.com/jimloco/Csocket.git;destsuffix=git/third_party/Csocket;name=Csocket \
+          "
+SRCREV_znc = "e661cdf9a394e2afd1b97517efa21fa2fa757e22"
+SRCREV_Csocket = "e8d9e0bb248c521c2c7fa01e1c6a116d929c41b4"
+
+# This constructs a composite revision based on multiple SRCREV's.
+#
+SRCREV_FORMAT = "znc_Csocket"
+
+S = "${WORKDIR}/git"
+
+inherit autotools-brokensep pkgconfig
+
+PACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'ipv6', d)}"
+PACKAGECONFIG[ipv6] = "--enable-ipv6,--disable-ipv6,"
+
+# ZNC has a custom autogen.sh that states that this command is needed *and* expected to fail
+do_configure_prepend() {
+    automake --add-missing || true
+}
+
+do_install_append() {
+    sed -i -e 's|${DEBUG_PREFIX_MAP}||g; s|--sysroot=${STAGING_DIR_TARGET}||g' ${D}${libdir}/pkgconfig/*.pc
+}