classes-dbus: general refactoring
Use the SystemdUnit parser to determine unit file properties.
Remove DBUS_ACTIVATED_SERVICE:
Rather, infer whether or not the service should be dbus activated
based on SystemdUnit results and act accordingly.
Change-Id: I87eed79b088d8531153e9d366e0f2d2e5ea73e5e
Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
diff --git a/meta-phosphor/common/recipes-phosphor/dbus/obmc-mapper.bb b/meta-phosphor/common/recipes-phosphor/dbus/obmc-mapper.bb
index ea38559..b516f68 100644
--- a/meta-phosphor/common/recipes-phosphor/dbus/obmc-mapper.bb
+++ b/meta-phosphor/common/recipes-phosphor/dbus/obmc-mapper.bb
@@ -11,7 +11,7 @@
DEPENDS += "systemd"
-DBUS_SERVICE_${PN} += "org.openbmc.ObjectMapper"
+DBUS_SERVICE_${PN} += "org.openbmc.ObjectMapper.service"
RDEPENDS_${PN} += " \
python-xml \
python-dbus \