meta-quanta: gbs: detect SlimSAS cable presence
Add gpio configuration for SlimSAS cable0~3 and
detect cables connected or not
(From meta-quanta rev: 09b8cd98a953ef96fabd7bc1c8d090bd02c53d88)
Signed-off-by: George Hung <george.hung@quantatw.com>
Change-Id: Ifee5ebf1a1055943ade8defce6be63b690bea8d2
Signed-off-by: Andrew Geissler <geissonator@yahoo.com>
diff --git a/meta-quanta/meta-gbs/recipes-gbs/detect-sas-cable/gbs-detect-sas-cable.bb b/meta-quanta/meta-gbs/recipes-gbs/detect-sas-cable/gbs-detect-sas-cable.bb
new file mode 100644
index 0000000..74785ef
--- /dev/null
+++ b/meta-quanta/meta-gbs/recipes-gbs/detect-sas-cable/gbs-detect-sas-cable.bb
@@ -0,0 +1,25 @@
+SUMMARY = "OpenBMC Quanta Detect SAS Cable Service"
+DESCRIPTION = "OpenBMC Quanta Detect SAS Cable Daemon."
+PR = "r1"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
+
+inherit systemd
+
+DEPENDS += "systemd"
+RDEPENDS_${PN} += "bash"
+
+SRC_URI = " file://detect-sas-cable.sh \
+ file://detect-sas-cable.service \
+ "
+
+do_install() {
+ install -d ${D}${bindir}
+ install -m 0755 ${WORKDIR}/detect-sas-cable.sh ${D}${bindir}/
+
+ install -d ${D}${systemd_system_unitdir}
+ install -m 0644 ${WORKDIR}/detect-sas-cable.service ${D}${systemd_system_unitdir}
+}
+
+SYSTEMD_PACKAGES = "${PN}"
+SYSTEMD_SERVICE_${PN} = "detect-sas-cable.service"