meta-openembedded: subtree update:713e70bd25..5caca0f7bd

Andreas Müller (1):
      fluidsynth: upgrade 2.1.2 -> 2.1.3

Domarys Correa (6):
      python3-pytest: Update 5.3.5 -> 5.4.2
      python3-pytest-html: Update 1.6 -> 2.1.1
      python3-pytest-metadata: Update 1.8.0 -> 1.9.0
      python3-pytest-asyncio: Update 0.10.0 -> 0.12.0
      python3-pyudev: Update 0.21.0 -> 0.22.0
      python3-pyyaml: Update 5.3 -> 5.3.1

Hongxu Jia (1):
      multipath-tools: fix compiling parallel issue

Kai Kang (1):
      plymouth: disable systemd-integration for sysvinit

Khem Raj (1):
      dfu-util-native: Remove DEPLOY_DIR_TOOLS from sstate-outputdirs

Konrad Weihmann (14):
      pugixml: fix typo for homepage
      distuils-extra: fix typo for DESCRIPTION
      brotli: fix typo for DESCRIPTION
      wxwidgets: fix typo for DESCRIPTION
      passwdqc: remove double modify operation
      zbar: fix typo for DESCRIPTION
      sound-theme-freedesktop: remove double depends
      python3-cmd2: remove double colorama in RDEPENDS
      python3-smbus2: remove duplicate RDEPENDS settings
      python3-twisted: remove double var modification
      spawn-fcgi: fix typo in SUMMARY
      physfs: fix typo for HOMEPAGE
      rest: fix typo for HOMEPAGE
      proftpd: Fix typo for SRC_URI[md5sum]

Leon Anavi (4):
      python3-click: Upgrade 7.0 -> 7.1.2
      python3-dbussy: Upgrade 1.2.1 -> 1.3
      python3-imageio: Upgrade 2.6.0 -> 2.8.0
      python3-colorama: Upgrade 0.4.1 -> 0.4.3

Maciej Pijanowski (1):
      qpdf: fix typo in RDEPENDS

Martin Jansa (1):
      irssi: package libirc_proxy.a in PN-staticdev

Michael Haener (1):
      cockpit: 219 -> 220

Patrick Williams (1):
      net-snmp: refresh patches

Pierre-Jean Texier (2):
      libuv: upgrade 1.36.0 -> 1.38.0
      uftp: upgrade 4.10.2 -> 5.0

Robert P. J. Day (1):
      use weak assignments for PNBLACKLIST in recipe files

Shlomi Vaknin (1):
      add python bitstring package

Zang Ruochen (6):
      libgphoto2: upgrade 2.5.24 -> 2.5.25
      rsyslog: upgrade 8.2002 -> 8.2004
      mosquitto: upgrade 1.6.9 -> 1.6.10
      snort: upgrade 2.9.15 -> 2.9.16
      wireshark: upgrade 3.2.2 -> 3.2.4
      cpuid: upgrade 20200211 -> 20200427

Zheng Ruoqin (5):
      nano: upgrade 4.9.2 -> 4.9.3
      gsoap: upgrade 2.8.100 -> 2.8.103
      logwatch: upgrade 7.5.1 -> 7.5.3
      mcelog: upgrade 168 -> 170
      libnet-dns-perl: upgrade 1.23 -> 1.24

Signed-off-by: Andrew Geissler <geissonator@yahoo.com>
Change-Id: I697f91df13d9e8d8cb15620aeccd644cdfe53a43
diff --git a/meta-openembedded/meta-perl/recipes-perl/libnet/libnet-dns-perl_1.24.bb b/meta-openembedded/meta-perl/recipes-perl/libnet/libnet-dns-perl_1.24.bb
new file mode 100644
index 0000000..8994f69
--- /dev/null
+++ b/meta-openembedded/meta-perl/recipes-perl/libnet/libnet-dns-perl_1.24.bb
@@ -0,0 +1,66 @@
+DESCRIPTION = "This package contains the DNS.pm module with friends."
+HOMEPAGE = "http://www.net-dns.org/"
+SECTION = "libs"
+LICENSE = "MIT"
+
+LIC_FILES_CHKSUM = "file://README;beginline=252;endline=269;md5=27db37b42cd1a5173a53922d67072bcb"
+
+DEPENDS += "perl"
+
+SRC_URI = "http://search.cpan.org/CPAN/authors/id/N/NL/NLNETLABS/Net-DNS-${PV}.tar.gz"
+
+SRC_URI[md5sum] = "1bf07817bb272d412a737ecc2347d70b"
+SRC_URI[sha256sum] = "11a6c2ba6cb1c6640f01c9bbf2036bcbe3974232e9b939ab94985230c92cde63"
+
+UPSTREAM_CHECK_REGEX = "Net\-DNS\-(?P<pver>(\d+\.\d+))(?!_\d+).tar"
+
+S = "${WORKDIR}/Net-DNS-${PV}"
+
+EXTRA_CPANFLAGS = "EXPATLIBPATH=${STAGING_LIBDIR} EXPATINCPATH=${STAGING_INCDIR}"
+
+inherit cpan ptest-perl
+
+RDEPENDS_${PN} = " \
+    libdigest-hmac-perl \
+    perl-module-base \
+    perl-module-constant \
+    perl-module-digest-md5 \
+    perl-module-digest-sha \
+    perl-module-file-spec \
+    perl-module-integer \
+    perl-module-io-file \
+    perl-module-io-select \
+    perl-module-io-socket \
+    perl-module-io-socket-ip \
+    perl-module-mime-base64 \
+    perl-module-scalar-util \
+    perl-module-test-more \
+    perl-module-time-local \
+"
+
+RRECOMMENDS_${PN} += " \
+    libnet-dns-sec-perl \
+"
+
+RDEPENDS_${PN}-ptest += " \
+    perl-module-encode \
+    perl-module-encode-byte \
+    perl-module-extutils-mm \
+    perl-module-extutils-mm-unix \
+    perl-module-overload \
+"
+
+python __anonymous () {
+    # rather than use "find" to determine libc-*.so,
+    # statically export the known paths for glibc and musl
+    import os
+    if d.getVar('TCLIBC') == "glibc":
+        os.environ["LIBC"] = "${STAGING_BASELIBDIR}/libc.so.6"
+    elif d.getVar('TCLIBC') == "musl":
+        os.environ["LIBC"] = "${STAGING_LIBDIR}/libc.so"
+    else:
+       raise bb.parse.SkipRecipe("incompatible with %s C library" %
+                                   d.getVar('TCLIBC'))
+}
+
+BBCLASSEXTEND = "native"