blob: aad1499b94d66aedd72d3b603e547131b38c010f [file] [log] [blame]
Brad Bishope42b3e32020-01-15 22:08:42 -05001SUMMARY = "Fast Log processor and Forwarder"
2DESCRIPTION = "Fluent Bit is a data collector, processor and \
3forwarder for Linux. It supports several input sources and \
4backends (destinations) for your data. \
5"
6
7HOMEPAGE = "http://fluentbit.io"
8BUGTRACKER = "https://github.com/fluent/fluent-bit/issues"
9
10LICENSE = "Apache-2.0"
11LIC_FILES_CHKSUM = "file://LICENSE;md5=2ee41112a44fe7014dce33e26468ba93"
12SECTION = "net"
13
14SRC_URI = "http://fluentbit.io/releases/1.3/fluent-bit-${PV}.tar.gz \
15 file://jemalloc.patch \
16 file://cross-build-init-system-detection.patch \
17 file://builtin-nan.patch \
18 "
19SRC_URI[md5sum] = "6eae6dfd0a874e5dd270c36e9c68f747"
20SRC_URI[sha256sum] = "e037c76c89269c8dc4027a08e442fefd2751b0f1e0f9c38f9a4b12d781a9c789"
21
22S = "${WORKDIR}/fluent-bit-${PV}"
23DEPENDS = "zlib bison-native flex-native"
24DEPENDS_append_libc-musl = " fts "
25
26INSANE_SKIP_${PN}-dev += "dev-elf"
27
28# Use CMake 'Unix Makefiles' generator
29OECMAKE_GENERATOR ?= "Unix Makefiles"
30
31# Fluent Bit build options
32# ========================
33
34# Host related setup
35EXTRA_OECMAKE += "-DGNU_HOST=${HOST_SYS} -DFLB_ALL=ON -DFLB_TD=1"
36
37# Disable LuaJIT and filter_lua support
38EXTRA_OECMAKE += "-DFLB_LUAJIT=Off -DFLB_FILTER_LUA=Off "
39
40# Disable Library and examples
41EXTRA_OECMAKE += "-DFLB_SHARED_LIB=Off -DFLB_EXAMPLES=Off "
42
43EXTRA_OECMAKE += "${@bb.utils.contains('DISTRO_FEATURES','systemd','-DFLB_SYSTEMD=On','',d)}"
44
45# Kafka Output plugin (disabled by default): note that when
46# enabling Kafka output plugin, the backend library librdkafka
47# requires 'openssl' as a dependency.
48#
49# DEPENDS += "openssl "
50# EXTRA_OECMAKE += "-DFLB_OUT_KAFKA=On "
51
52inherit cmake systemd features_check
53
54SYSTEMD_SERVICE_${PN} = "td-agent-bit.service"
55TARGET_CC_ARCH_append = " ${SELECTED_OPTIMIZATION}"