blob: d7b1dfaad3f38185993aeb6f05d09dcc6fbfbd16 [file] [log] [blame]
Brad Bishopd7bf8c12018-02-25 22:55:05 -05001SUMMARY = "Virtual EtherDrive blade AoE target"
2SECTION = "admin"
3
4LICENSE = "GPLv2"
5LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f"
6
7SRC_URI = "${SOURCEFORGE_MIRROR}/aoetools/${BP}.tar.gz \
8 file://cross.patch \
9 file://makefile-add-ldflags.patch \
10 file://${BPN}.conf \
11 file://${BPN}.init \
12 file://${BPN}.service \
13 file://volatiles.99_vblade \
14 "
15
16SRC_URI[md5sum] = "510d98ba0f231284a5fbe2da11cb2d6e"
17SRC_URI[sha256sum] = "a990378f273f10eb431e42954a871aed52714035bbab28c54cef600c458356bb"
18
19inherit autotools-brokensep update-rc.d systemd
20
21do_install() {
22 install -D -m 0755 ${S}/vblade ${D}/${sbindir}/vblade
23 install -D -m 0755 ${S}/vbladed ${D}/${sbindir}/vbladed
24 install -D -m 0644 ${S}/vblade.8 ${D}/${mandir}/man8/vblade.8
25
26 install -D -m 0644 ${WORKDIR}/${BPN}.conf ${D}/${sysconfdir}/${BPN}.conf
27 install -D -m 0755 ${WORKDIR}/${BPN}.init ${D}/${sysconfdir}/init.d/${BPN}
28
29 if ${@bb.utils.contains('DISTRO_FEATURES', 'sysvinit', 'true', 'false', d)}; then
30 install -d ${D}/${sysconfdir}/default/volatiles
31 install -m 0755 ${WORKDIR}/volatiles.99_vblade ${D}/${sysconfdir}/default/volatiles/99_vblade
32 fi
33
34 if ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'true', 'false', d)}; then
35 install -d ${D}/${bindir}
36 install -m 0755 ${WORKDIR}/${BPN}.init ${D}/${bindir}/
37 install -d ${D}${sysconfdir}/tmpfiles.d
38 echo "d /var/run/${BPN} 0755 root root -" > ${D}${sysconfdir}/tmpfiles.d/${BPN}.conf
39
40 install -d ${D}${systemd_system_unitdir}
41 install -m 0644 ${WORKDIR}/vblade.service ${D}${systemd_system_unitdir}
42 sed -e 's,@BINDIR@,${bindir},g' -i ${D}${systemd_system_unitdir}/*.service
43 fi
44
45}
46
47INITSCRIPT_NAME = "vblade"
48INITSCRIPT_PARAMS = "start 30 . stop 70 0 1 2 3 4 5 6 ."
49
50SYSTEMD_SERVICE_${PN} = "vblade.service"
51SYSTEMD_AUTO_ENABLE = "disable"