Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 1 | require qemu.inc |
| 2 | |
| 3 | inherit ptest |
| 4 | |
| 5 | RDEPENDS_${PN}-ptest = "bash make" |
| 6 | |
| 7 | LIC_FILES_CHKSUM = "file://COPYING;md5=441c28d2cf86e15a37fa47e15a72fbac \ |
| 8 | file://COPYING.LIB;endline=24;md5=c04def7ae38850e7d3ef548588159913" |
| 9 | |
| 10 | SRC_URI = "http://wiki.qemu-project.org/download/${BP}.tar.bz2 \ |
| 11 | file://powerpc_rom.bin \ |
| 12 | file://disable-grabs.patch \ |
| 13 | file://wacom.patch \ |
| 14 | file://add-ptest-in-makefile-v10.patch \ |
| 15 | file://run-ptest \ |
| 16 | file://qemu-enlarge-env-entry-size.patch \ |
| 17 | file://no-valgrind.patch \ |
| 18 | file://pathlimit.patch \ |
| 19 | file://qemu-2.5.0-cflags.patch \ |
| 20 | file://chardev-connect-socket-to-a-spawned-command.patch \ |
| 21 | file://apic-fixup-fallthrough-to-PIC.patch \ |
| 22 | file://linux-user-Fix-webkitgtk-hangs-on-32-bit-x86-target.patch \ |
| 23 | file://memfd.patch \ |
| 24 | file://0001-arm-translate-a64-treat-DISAS_UPDATE-as-variant-of-D.patch \ |
| 25 | file://check-PS2Queue-pointers-in-post_load-routine.patch \ |
| 26 | " |
| 27 | UPSTREAM_CHECK_REGEX = "qemu-(?P<pver>\d+\..*)\.tar" |
| 28 | |
| 29 | |
| 30 | SRC_URI_append_class-native = " \ |
| 31 | file://fix-libcap-header-issue-on-some-distro.patch \ |
| 32 | file://cpus.c-qemu_cpu_kick_thread_debugging.patch \ |
| 33 | " |
| 34 | |
| 35 | SRC_URI[md5sum] = "61cf862b6007eba4ac98247776af2e27" |
| 36 | SRC_URI[sha256sum] = "d9df2213ceed32e91dab7bc9dd19c1af83f91ba72c7aeef7605dfaaf81732ccb" |
| 37 | |
| 38 | COMPATIBLE_HOST_mipsarchn32 = "null" |
| 39 | COMPATIBLE_HOST_mipsarchn64 = "null" |
| 40 | |
| 41 | do_install_append() { |
| 42 | # Prevent QA warnings about installed ${localstatedir}/run |
| 43 | if [ -d ${D}${localstatedir}/run ]; then rmdir ${D}${localstatedir}/run; fi |
| 44 | install -Dm 0755 ${WORKDIR}/powerpc_rom.bin ${D}${datadir}/qemu |
| 45 | } |
| 46 | |
| 47 | do_compile_ptest() { |
| 48 | make buildtest-TESTS |
| 49 | } |
| 50 | |
| 51 | do_install_ptest() { |
| 52 | cp -rL ${B}/tests ${D}${PTEST_PATH} |
| 53 | find ${D}${PTEST_PATH}/tests -type f -name "*.[Sshcod]" | xargs -i rm -rf {} |
| 54 | |
| 55 | cp ${S}/tests/Makefile.include ${D}${PTEST_PATH}/tests |
| 56 | # Don't check the file genreated by configure |
| 57 | sed -i -e '/wildcard config-host.mak/d' \ |
| 58 | -e '$ {/endif/d}' ${D}${PTEST_PATH}/tests/Makefile.include |
| 59 | } |