Add Supprt for P9 Attribute/Targeting Read/Write Partition

This commit adds support for an attribute/targeting Read-Write partition
called HBD_RW ("HB_DATA_RW") in P8 OpenPower systems. The P8 PNOR XML
Layout files had this partiontion added, while the P9 PNOR XML Layout files
did not.  The common PNOR files update_image.pl and create_pnor_image.pl
were udpated to handle whether or not HBD_RW was part of the layout.
The hostboot-p8 code (via the hostboot 'master-p8' branch) was also updated
to handle this new HBD_RW PNOR partition.

Signed-off-by: Mike Baiocchi <mbaiocch@us.ibm.com>
diff --git a/openpower/package/hostboot-p8/hostboot-p8.mk b/openpower/package/hostboot-p8/hostboot-p8.mk
index adf260a..5fb5840 100644
--- a/openpower/package/hostboot-p8/hostboot-p8.mk
+++ b/openpower/package/hostboot-p8/hostboot-p8.mk
@@ -3,7 +3,7 @@
 # hostboot for POWER8
 #
 ################################################################################
-HOSTBOOT_P8_VERSION ?= 92e482dc468490502ab431663eb46d4f025913ea
+HOSTBOOT_P8_VERSION ?= c35645e2d863e37a4356d141713e082505c51e94
 
 HOSTBOOT_P8_SITE ?= $(call github,open-power,hostboot,$(HOSTBOOT_P8_VERSION))