Split P8 and P9 Hostboot and OCC packages
This was causing a couple of issues:
1) increased complexity in build files
2) It breaks the pkg-version patch detection/checksum
3) Failing to apply patches to would silently fail
The split makes this a bit easier and requires less custom code.
We keep the P9 hostboot/occ named hostboot/occ, so that day-to-day,
nobody notices a difference. The only difference you'll notice
is if doing POWER8 hostboot/occ development, as the package name
will be 'hostboot-p8' or 'occ-p8'.
Fixes: https://github.com/open-power/op-build/issues/876
Fixes: https://github.com/open-power/op-build/issues/1194
Signed-off-by: Stewart Smith <stewart@linux.vnet.ibm.com>
diff --git a/openpower/package/machine-xml/machine-xml.mk b/openpower/package/machine-xml/machine-xml.mk
index e335e8b..dc05d0d 100644
--- a/openpower/package/machine-xml/machine-xml.mk
+++ b/openpower/package/machine-xml/machine-xml.mk
@@ -13,7 +13,14 @@
MACHINE_XML_LICENSE = Apache-2.0
MACHINE_XML_LICENSE_FILES = LICENSE
-MACHINE_XML_DEPENDENCIES = hostboot openpower-mrw common-p8-xml
+MACHINE_XML_DEPENDENCIES = openpower-mrw common-p8-xml
+
+ifeq ($(BR2_OPENPOWER_POWER9),y)
+MACHINE_XML_DEPENDENCIES += hostboot
+endif
+ifeq ($(BR2_OPENPOWER_POWER8),y)
+MACHINE_XML_DEPENDENCIES += hostboot-p8
+endif
MACHINE_XML_INSTALL_IMAGES = YES
MACHINE_XML_INSTALL_TARGET = YES