Split P8 and P9 Hostboot and OCC packages

This was causing a couple of issues:
1) increased complexity in build files
2) It breaks the pkg-version patch detection/checksum
3) Failing to apply patches to would silently fail

The split makes this a bit easier and requires less custom code.

We keep the P9 hostboot/occ named hostboot/occ, so that day-to-day,
nobody notices a difference. The only difference you'll notice
is if doing POWER8 hostboot/occ development, as the package name
will be 'hostboot-p8' or 'occ-p8'.

Fixes: https://github.com/open-power/op-build/issues/876
Fixes: https://github.com/open-power/op-build/issues/1194
Signed-off-by: Stewart Smith <stewart@linux.vnet.ibm.com>
diff --git a/openpower/package/occ-p8/occ-p8.mk b/openpower/package/occ-p8/occ-p8.mk
new file mode 100644
index 0000000..7f64e59
--- /dev/null
+++ b/openpower/package/occ-p8/occ-p8.mk
@@ -0,0 +1,35 @@
+################################################################################
+#
+# occ for power8
+#
+################################################################################
+
+OCC_P8_VERSION ?= 28f2cec690b7f19548ce860a8820f519e6c39a6a
+OCC_P8_SITE ?= $(call github,open-power,occ,$(OCC_P8_VERSION))
+OCC_P8_LICENSE = Apache-2.0
+
+OCC_P8_LICENSE_FILES = src/LICENSE
+
+OCC_P8_INSTALL_IMAGES = YES
+OCC_P8_INSTALL_TARGET = NO
+
+OCC_P8_STAGING_DIR = $(STAGING_DIR)/occ
+
+OCC_P8_IMAGE_BIN_PATH = src/image.bin
+OCC_P8_DEPENDENCIES = host-binutils host-p8-pore-binutils
+
+define OCC_P8_BUILD_CMDS
+        cd $(@D)/src && \
+        make POREPATH=$(P8_PORE_BINUTILS_BIN)/bin/ OCC_OP_BUILD=1 CROSS_PREFIX=$(TARGET_CROSS) all && \
+        make tracehash && \
+        make combineImage
+endef
+
+OCC_P8_BUILD_CMDS ?= $(OCC_P8_BUILD_CMDS_P8)
+
+define OCC_P8_INSTALL_IMAGES_CMDS
+       mkdir -p $(STAGING_DIR)/occ
+       cp $(@D)/$(OCC_P8_IMAGE_BIN_PATH) $(OCC_P8_STAGING_DIR)/$(BR2_OCC_P8_BIN_FILENAME)
+endef
+
+$(eval $(generic-package))