platform-xml: DEPENDENCIES is a list of packages, not targets
The current $target-xml packages use target names in their dependencies
lists, where they should be using package names. This breaks certain
targets, like 'legal-info', which create dependencies by adding other
suffixes to the package names.
From the buildroot manual:
These dependencies are listed in terms of lower-case package names,
which can be packages for the target (without the host- prefix) or
packages for the host (with the host-) prefix). Buildroot will ensure
that all these packages are built and installed before the current
package starts its configuration.
This change fixed these DEPENDENCIES defintions to use package names
instead. Consequently, we don't need to filter out the -install-images
target suffix in the op-target-dependencies script.
Fixes #547.
Signed-off-by: Jeremy Kerr <jk@ozlabs.org>
diff --git a/openpower/package/habanero-xml/habanero-xml.mk b/openpower/package/habanero-xml/habanero-xml.mk
index 07b8a36..307c47d 100644
--- a/openpower/package/habanero-xml/habanero-xml.mk
+++ b/openpower/package/habanero-xml/habanero-xml.mk
@@ -8,7 +8,7 @@
HABANERO_XML_SITE ?= $(call github,open-power,habanero-xml,$(HABANERO_XML_VERSION))
HABANERO_XML_LICENSE = Apache-2.0
-HABANERO_XML_DEPENDENCIES = hostboot-install-images openpower-mrw-install-images common-p8-xml-install-images
+HABANERO_XML_DEPENDENCIES = hostboot openpower-mrw common-p8-xml
HABANERO_XML_INSTALL_IMAGES = YES
HABANERO_XML_INSTALL_TARGET = YES