Enable P10 HCODE and HOSTBOOT_BINARIES compilation
- Implement makefiles for hostboot_binaries and hcode
to build the p10 content
- Add an override ENV Var to use a binary version of hcode
instead of compiling the source code
- Binary used for override is release: hw112519a.opmst10
diff --git a/openpower/package/hostboot-binaries/hostboot_binaries.mk b/openpower/package/hostboot-binaries/hostboot_binaries.mk
index c8b2c13..bd22b3a 100644
--- a/openpower/package/hostboot-binaries/hostboot_binaries.mk
+++ b/openpower/package/hostboot-binaries/hostboot_binaries.mk
@@ -4,9 +4,12 @@
#
################################################################################
-
HOSTBOOT_BINARIES_VERSION = $(call qstrip,$(BR2_HOSTBOOT_BINARIES_VERSION))
-HOSTBOOT_BINARIES_SITE ?= $(call github,open-power,hostboot-binaries,$(HOSTBOOT_BINARIES_VERSION))
+# TODO: WORKAROUND: Need to reenable next line and comment out the two lines
+# after that, when code is propagated to a public repo
+#HOSTBOOT_BINARIES_SITE ?= $(call github,open-power,hostboot-binaries,$(HOSTBOOT_BINARIES_VERSION))
+HOSTBOOT_BINARIES_SITE ?= git@github.ibm.com:open-power/hostboot-binaries.git
+HOSTBOOT_BINARIES_SITE_METHOD ?= git
HOSTBOOT_BINARIES_LICENSE = Apache-2.0
HOSTBOOT_BINARIES_LICENSE_FILES = LICENSE
@@ -56,24 +59,33 @@
endif
###################################
-# P10:
-ifeq ($(BR2_OPENPOWER_POWER10),y)
+# P10 Workaround
+ifeq ($(BR2_HOSTBOOT_BINARIES_USE_HCODE_BIN),y)
-# TODO: Update for P10
-NIMBUS_RING_FILE=p9n.hw.rings.bin
-NIMBUS_RING_OVERLAYS_FILE=p9n.hw.overlays.bin
-AXONE_RING_FILE=p9a.hw.rings.bin
-AXONE_RING_OVERLAYS_FILE=p9a.hw.overlays.bin
+HCODE_BIN_FILE=p10.ref_image.bin
define HOSTBOOT_BINARIES_INSTALL_IMAGES_CMDS
- $(INSTALL) -D $(@D)/cvpd.bin $(STAGING_DIR)/hostboot_binaries/cvpd.bin
+ $(INSTALL) -D $(@D)/gpu_gpe1.bin $(STAGING_DIR)/hostboot_binaries/gpu_gpe1.bin
+ $(INSTALL) -D $(@D)/$(HCODE_BIN_FILE) $(STAGING_DIR)/hostboot_binaries/$(HCODE_BIN_FILE)
+ $(INSTALL) -D $(@D)/$(BR2_HOSTBOOT_BINARY_IONV_FILENAME) $(STAGING_DIR)/hostboot_binaries/
+ $(INSTALL) -D $(@D)/$(BR2_HOSTBOOT_BINARY_SBEC_FILENAME) $(STAGING_DIR)/hostboot_binaries/
+endef
+
+else ifeq ($(BR2_OPENPOWER_POWER10),y)
+
+P10_RING_DYNAMIC_FILE=p10.hw.dynamic.bin
+P10_RING_OVERLAYS_FILE=p10.hw.overlays.bin
+P10_RING_QME_FILE=p10.hw.qme.rings.bin
+P10_RING_SBE_FILE=p10.hw.sbe.rings.bin
+
+define HOSTBOOT_BINARIES_INSTALL_IMAGES_CMDS
$(INSTALL) -D $(@D)/gpu_gpe1.bin $(STAGING_DIR)/hostboot_binaries/gpu_gpe1.bin
$(INSTALL) -D $(@D)/$(BR2_HOSTBOOT_BINARY_IONV_FILENAME) $(STAGING_DIR)/hostboot_binaries/
$(INSTALL) -D $(@D)/$(BR2_HOSTBOOT_BINARY_SBEC_FILENAME) $(STAGING_DIR)/hostboot_binaries/
- $(INSTALL) -D $(@D)/$(NIMBUS_RING_FILE) $(STAGING_DIR)/hostboot_binaries/
- $(INSTALL) -D $(@D)/$(NIMBUS_RING_OVERLAYS_FILE) $(STAGING_DIR)/hostboot_binaries/
- $(INSTALL) -D $(@D)/$(AXONE_RING_FILE) $(STAGING_DIR)/hostboot_binaries/
- $(INSTALL) -D $(@D)/$(AXONE_RING_OVERLAYS_FILE) $(STAGING_DIR)/hostboot_binaries/
+ $(INSTALL) -D $(@D)/$(P10_RING_DYNAMIC_FILE) $(STAGING_DIR)/hostboot_binaries/
+ $(INSTALL) -D $(@D)/$(P10_RING_OVERLAYS_FILE) $(STAGING_DIR)/hostboot_binaries/
+ $(INSTALL) -D $(@D)/$(P10_RING_QME_FILE) $(STAGING_DIR)/hostboot_binaries/
+ $(INSTALL) -D $(@D)/$(P10_RING_SBE_FILE) $(STAGING_DIR)/hostboot_binaries/
endef
endif