Fixes to get witherspoon xml working with latest hb
diff --git a/openpower/package/witherspoon-xml/witherspoon.mk b/openpower/package/witherspoon-xml/witherspoon.mk
index 79955ea..2975378 100644
--- a/openpower/package/witherspoon-xml/witherspoon.mk
+++ b/openpower/package/witherspoon-xml/witherspoon.mk
@@ -4,7 +4,7 @@
#
################################################################################
-WITHERSPOON_XML_VERSION ?= 3a89d5efc33377302418c06d654cc3356561c797
+WITHERSPOON_XML_VERSION ?=5cfb191919a40752001e5918fb84dd64a783a00a
WITHERSPOON_XML_SITE ?= $(call github,open-power,witherspoon-xml,$(WITHERSPOON_XML_VERSION))
WITHERSPOON_XML_LICENSE = Apache-2.0
@@ -35,12 +35,24 @@
perl -I $(MRW_HB_TOOLS) \
$(MRW_HB_TOOLS)/processMrw.pl -x $(MRW_SCRATCH)/witherspoon.xml
+ chmod +x $(MRW_HB_TOOLS)/filter_out_unwanted_attributes.pl
+
+ $(MRW_HB_TOOLS)/filter_out_unwanted_attributes.pl \
+ --tgt-xml $(MRW_HB_TOOLS)/target_types_merged.xml \
+ --tgt-xml $(MRW_HB_TOOLS)/target_types_hb.xml \
+ --tgt-xml $(MRW_HB_TOOLS)/target_types_oppowervm.xml \
+ --mrw-xml $(MRW_SCRATCH)/WITHERSPOON_hb.mrw.xml
+
+ cp $(MRW_SCRATCH)/WITHERSPOON_hb.mrw.xml.updated $(MRW_SCRATCH)/WITHERSPOON_hb.mrw.xml
+
# merge in any system specific attributes, hostboot attributes
$(MRW_HB_TOOLS)/mergexml.sh $(MRW_SCRATCH)/$(BR2_WITHERSPOON_SYSTEM_XML_FILENAME) \
$(MRW_HB_TOOLS)/attribute_types.xml \
$(MRW_HB_TOOLS)/attribute_types_hb.xml \
+ $(MRW_HB_TOOLS)/attribute_types_oppowervm.xml \
$(MRW_HB_TOOLS)/target_types_merged.xml \
$(MRW_HB_TOOLS)/target_types_hb.xml \
+ $(MRW_HB_TOOLS)/target_types_oppowervm.xml \
$(MRW_SCRATCH)/$(BR2_WITHERSPOON_MRW_XML_FILENAME) > $(MRW_HB_TOOLS)/temporary_hb.hb.xml;
# creating the targeting binary