ppe42-binutils,ppe42-gcc: Patch, use $(MAKE) and -Wno-error to fix build on modern GCC

Because building a compiler with -Wno-error to avoid erorring out on
undefined behaviour is a good idea.

We build with $(MAKE) so that we get the -j option passed down from
buildroot. this speeds up build by a couple of orders of magnitude
on my build machine.

Fixes: https://github.com/open-power/op-build/issues/803
Signed-off-by: Stewart Smith <stewart@linux.vnet.ibm.com>
diff --git a/openpower/package/ppe42-gcc/ppe42-gcc.mk b/openpower/package/ppe42-gcc/ppe42-gcc.mk
index 2ebdf5b..0a8bc23 100644
--- a/openpower/package/ppe42-gcc/ppe42-gcc.mk
+++ b/openpower/package/ppe42-gcc/ppe42-gcc.mk
@@ -25,8 +25,8 @@
                     --with-gmp=$(HOST_DIR)/usr \
                     --with-mpfr=$(HOST_DIR)/usr \
                     && \
-        make configure-host && \
-        make all-gcc
+        $(MAKE) configure-host && \
+        $(MAKE) CFLAGS=-Wno-error all-gcc
 endef
 
 define HOST_PPE42_GCC_INSTALL_CMDS