blob: 4c663583968568129320ce82833e5e2c76c75f4b [file] [log] [blame]
Nick Bofferdingf390b6f2019-10-08 11:55:42 -05001################################################################################
2#
3# SBE for P10
4#
5################################################################################
6
7SBE_P10_VERSION = $(call qstrip,$(BR2_SBE_P10_VERSION))
8# TODO: WORKAROUND: Need to reenable next line and comment out the two lines
9# after that, when code is propagated to a public repo
10#SBE_P10_SITE = $(call github,open-power,sbe,$(SBE_P10_VERSION))
Nick Bofferding6c26bb72019-10-09 16:40:52 -050011SBE_P10_SITE = git@github.ibm.com:open-power/sbe.git
Nick Bofferdingf390b6f2019-10-08 11:55:42 -050012SBE_P10_SITE_METHOD=git
13
14SBE_P10_LICENSE = Apache-2.0
15SBE_P10_DEPENDENCIES = host-ppe42-gcc hcode-p10
16# TODO WORKAROUND ... host-ppe42-gc not compiling
17# host-ppe42-gcc hcode-p10
18
19SBE_P10_INSTALL_IMAGES = YES
20SBE_P10_INSTALL_TARGET = NO
21
22define SBE_P10_BUILD_CMDS
23 SBE_COMMIT_ID=$(SBE_P10_VERSION) $(MAKE) -C $(@D) \
24 LD_LIBRARY_PATH=$(HOST_DIR)/usr/lib \
25 CROSS_COMPILER_PATH=$(PPE42_GCC_BIN) \
26 all
27endef
28
29define SBE_P10_INSTALL_IMAGES_CMDS
30 $(INSTALL) -D $(@D)/images/ipl_image_tool $(HOST_DIR)/usr/bin/
31 python $(@D)/src/build/sbeOpDistribute.py --sbe_binary_dir=$(STAGING_DIR)/sbe_binaries --img_dir=$(@D)/images --sbe_binary_filename $(BR2_HOSTBOOT_BINARY_SBE_FILENAME)
32 cp $(@D)/src/build/sbeOpDistribute.py $(STAGING_DIR)/sbe_binaries/
33endef
34
35$(eval $(generic-package))