kernel: FSI improvements, hwrng fix
Benjamin Herrenschmidt (13):
fsi/fsi-master-gpio: Implement CRC error recovery
fsi/fsi-master-gpio: More error handling cleanup
fsi: Remove old sbefifo driver
fsi/sbefifo: Add driver for the SBE FIFO
fsi/fsi-occ: Simple conversion to new sbefifo driver
fsi/occ: Don't set driver data late
hwmon/occ: Silence probe error message when host is shutdown
fsi/scom: Add mutex around FSI2PIB accesses
fsi/scom: Whitespace fixes
fsi/scom: Fixup endian annotations
hwmon: occ: Display info about the OCC code level and sensors found
hwmon: occ: Avoid displaying an error when host is down
hwmon: occ: Properly initialize sysfs attributes
Eddie James (1):
fsi: scom: Remove PIB reset during probe
Jeremy Kerr (3):
fsi/gpio: Include command build in locked section
fsi/gpio: Use relative-addressing commands
fsi/master-gpio: Replace bit_bit lock with IRQ disable/enable
Joel Stanley (1):
ARM: dts: aspeed: Fix hwrng register address
Change-Id: I71e66787fd621c97200cf58e674baa1bf3f937cb
Tested: Use of pdbg, cronus and host boot testing on Romulus
Signed-off-by: Joel Stanley <joel@jms.id.au>
diff --git a/meta-phosphor/common/recipes-kernel/linux/linux-obmc_4.13.bb b/meta-phosphor/common/recipes-kernel/linux/linux-obmc_4.13.bb
index 22b6baa..6207a0a 100644
--- a/meta-phosphor/common/recipes-kernel/linux/linux-obmc_4.13.bb
+++ b/meta-phosphor/common/recipes-kernel/linux/linux-obmc_4.13.bb
@@ -1,6 +1,6 @@
KBRANCH ?= "dev-4.13"
LINUX_VERSION ?= "4.13.16"
-SRCREV="60850f7b3165a1e3adb524b4c07d48361d2d255e"
+SRCREV="aca92be80c008bceeb6fb62fd1d450b5be5d0a4f"
require linux-obmc.inc